summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-03 08:13:52 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-03 08:13:52 +0200
commitdf40fee701f7f15db7b07124fd13517cc6b349b8 (patch)
treeb096330027ec64f8c965b82e9ff2bacc551984a5 /dev-python/keyring
parentdev-python/validators: Bump to 0.26.0 (diff)
downloadgentoo-df40fee701f7f15db7b07124fd13517cc6b349b8.tar.gz
gentoo-df40fee701f7f15db7b07124fd13517cc6b349b8.tar.bz2
gentoo-df40fee701f7f15db7b07124fd13517cc6b349b8.zip
dev-python/keyring: Bump to 25.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/keyring')
-rw-r--r--dev-python/keyring/Manifest1
-rw-r--r--dev-python/keyring/keyring-25.0.1.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/dev-python/keyring/Manifest b/dev-python/keyring/Manifest
index 815cc8fbe976..0855982a8cea 100644
--- a/dev-python/keyring/Manifest
+++ b/dev-python/keyring/Manifest
@@ -1,2 +1,3 @@
DIST keyring-24.3.1.tar.gz 60454 BLAKE2B cb0a9b82163febbbd737f2f25353bf96cbb7b8a87c7db00523960b3fce5595c6af65bc02b7d070b0fa5a466fc53530975de8f7a44ab9a9f783d2db34b1a67901 SHA512 53f26763175c7f1de041d8805062696ef3ef6c79792cdc75ae72621da8e729ac4cbb6e76937db2a0a5ce4bc41ab92c164d62e4627f92edab8c0d0fc02ca4980e
DIST keyring-25.0.0.tar.gz 59863 BLAKE2B b1b955215bf197f52e64c46572f29c2059f75f5eadce249fe1776f10f7f1c6d20428a811a8c36fe4bb85142f61f6281c71e2b97b1f8657fdc35a5075b840d39f SHA512 9b7f25aea1166f80b1b6ded7d691295690dac679e9f931437ae83fc2bf465c541bb1ed74b99a0de749a04df60576e9fe068f2f86b39a3c5bcef953b616678951
+DIST keyring-25.0.1.tar.gz 60063 BLAKE2B 1ffddfa13b672b9811069c09870ab59b9ab3f613ac0348302a14e5475b541f16dd923f20c09dd3d08767b3174eef93716dffd2898585ab12dee9d04f06a43fdb SHA512 3f18b670631e4f0f3ebb06184b6c07e19fe7184b7fe0512531f8d532de296641ceb753b4988b0f6f1ada37d5da4fb1696f2af450b7eeb24e0a0b9ea2ac769ef5
diff --git a/dev-python/keyring/keyring-25.0.1.ebuild b/dev-python/keyring/keyring-25.0.1.ebuild
new file mode 100644
index 000000000000..4e1deec56116
--- /dev/null
+++ b/dev-python/keyring/keyring-25.0.1.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Provides access to the system keyring service"
+HOMEPAGE="
+ https://github.com/jaraco/keyring/
+ https://pypi.org/project/keyring/
+"
+
+LICENSE="PSF-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ >=dev-python/secretstorage-3.2[${PYTHON_USEDEP}]
+ dev-python/jaraco-classes[${PYTHON_USEDEP}]
+ dev-python/jaraco-context[${PYTHON_USEDEP}]
+ dev-python/jaraco-functools[${PYTHON_USEDEP}]
+ >=dev-python/jeepney-0.4.2[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/importlib-metadata-4.11.4[${PYTHON_USEDEP}]
+ ' 3.10 3.11)
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # this test fails if importlib-metadata returns more than one
+ # entry, i.e. when keyring is installed already
+ tests/test_packaging.py::test_entry_point
+ )
+ local EPYTEST_IGNORE=(
+ # apparently does not unlock the keyring properly
+ tests/backends/test_libsecret.py
+ # hangs
+ tests/backends/test_kwallet.py
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -o addopts=
+}