summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-05-24 14:39:29 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2016-05-24 18:16:25 -0500
commit7d017a1dbcb82d41e70662fbc4afb6a76d1f5679 (patch)
treebedf06d737cab0d89d4b59b3d36eb0f769845730 /dev-python/keystoneauth/keystoneauth-2.4.1.ebuild
parentdev-perl/Test-Number-Delta: Remove old (diff)
downloadgentoo-7d017a1dbcb82d41e70662fbc4afb6a76d1f5679.tar.gz
gentoo-7d017a1dbcb82d41e70662fbc4afb6a76d1f5679.tar.bz2
gentoo-7d017a1dbcb82d41e70662fbc4afb6a76d1f5679.zip
dev-python/keystoneauth: bup
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-python/keystoneauth/keystoneauth-2.4.1.ebuild')
-rw-r--r--dev-python/keystoneauth/keystoneauth-2.4.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/keystoneauth/keystoneauth-2.4.1.ebuild b/dev-python/keystoneauth/keystoneauth-2.4.1.ebuild
new file mode 100644
index 000000000000..fa1557e802fc
--- /dev/null
+++ b/dev-python/keystoneauth/keystoneauth-2.4.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="This package contains tools for authenticating to an OpenStack-based cloud."
+HOMEPAGE="https://github.com/openstack/keystoneauth"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}1/${PN}1-${PV}.tar.gz"
+S="${WORKDIR}/${PN}1-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-1.6[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="${CDEPEND}
+ >=dev-python/iso8601-0.1.9[${PYTHON_USEDEP}]
+ >=dev-python/positional-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.8.1[${PYTHON_USEDEP}]
+ !~dev-python/requests-2.9.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.5.0[${PYTHON_USEDEP}]"