summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-04-09 01:51:05 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-04-09 02:05:38 -0500
commit6c94a5bfce6a908e12fc7635f99c3d84540a4ae9 (patch)
tree8735d85ecaa3cf3627e898968d65060ff3069876 /dev-python/keystoneauth/keystoneauth-3.13.1.ebuild
parentdev-python/pysaml2: 4.6.5 add py37 support (diff)
downloadgentoo-6c94a5bfce6a908e12fc7635f99c3d84540a4ae9.tar.gz
gentoo-6c94a5bfce6a908e12fc7635f99c3d84540a4ae9.tar.bz2
gentoo-6c94a5bfce6a908e12fc7635f99c3d84540a4ae9.zip
dev-python/keystoneauth: 3.13.1 bump
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/keystoneauth/keystoneauth-3.13.1.ebuild')
-rw-r--r--dev-python/keystoneauth/keystoneauth-3.13.1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/keystoneauth/keystoneauth-3.13.1.ebuild b/dev-python/keystoneauth/keystoneauth-3.13.1.ebuild
new file mode 100644
index 000000000000..6c75c291f6e5
--- /dev/null
+++ b/dev-python/keystoneauth/keystoneauth-3.13.1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 python3_6 python3_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="This package contains tools for authenticating to an OpenStack-based cloud."
+HOMEPAGE="https://github.com/openstack/keystoneauth"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}1/${PN}1-${PV}.tar.gz"
+S="${WORKDIR}/${PN}1-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="${CDEPEND}
+ >=dev-python/iso8601-0.1.11[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ >=dev-python/six-1.10.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]
+ >=dev-python/os-service-types-1.2.0[${PYTHON_USEDEP}]"