summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2016-03-29 13:25:04 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2016-03-29 13:25:04 -0500
commit89edfcdf5872fe92c97f05959a8fd35b106b3016 (patch)
treebf0a4f9239b28c9178dac69b31c91b46528dbcbf /dev-python/keystoneauth
parentsys-cluster/neutron: bup (diff)
downloadgentoo-89edfcdf5872fe92c97f05959a8fd35b106b3016.tar.gz
gentoo-89edfcdf5872fe92c97f05959a8fd35b106b3016.tar.bz2
gentoo-89edfcdf5872fe92c97f05959a8fd35b106b3016.zip
dev-python/keystoneauth: bup
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-python/keystoneauth')
-rw-r--r--dev-python/keystoneauth/Manifest1
-rw-r--r--dev-python/keystoneauth/keystoneauth-2.4.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/keystoneauth/Manifest b/dev-python/keystoneauth/Manifest
index 41e622ab6098..e1ffdccbed8b 100644
--- a/dev-python/keystoneauth/Manifest
+++ b/dev-python/keystoneauth/Manifest
@@ -1 +1,2 @@
DIST keystoneauth1-2.3.0.tar.gz 149266 SHA256 27262621a8e74fe296f3c23a4b43dc9c1422670e89568626eb511163cb1c567c SHA512 e41a84e46247abf54073d8aa978d5e0db8341bff6507d9cb7079230381e10ccd7f72f5478849c37d8e914b520392762270bf0495d0945e7a7b3e5cd72fdced34 WHIRLPOOL 41fe83b35055975ad4ff99a387e30aa512ea071856034ace7804b3ea6f7c9378f4b2268b9df023e92ccea92807b47bdfafffef9e964336acca36599c288654d2
+DIST keystoneauth1-2.4.0.tar.gz 151550 SHA256 4d7fda675f47cab4456f0a4bae91899b37f38d540a6f0972a93935c75df8cb53 SHA512 69614a96cddfa6652ba5ca0abcd44305be605c1b1359a62aadc8e5315a9ddb3442eef677688e8646feaab0d184d4a9c96071effb1b2b9044b7362c1727868ab6 WHIRLPOOL 91994ee1639e5f8da3a85560a53b61fa71ed8653d11ff897b05d06c7c3fb06b38803e0488fdbc9d8b953284f2b2a2fd7c6136a38f1aa3b4e669fb5daf044c69d
diff --git a/dev-python/keystoneauth/keystoneauth-2.4.0.ebuild b/dev-python/keystoneauth/keystoneauth-2.4.0.ebuild
new file mode 100644
index 000000000000..fa1557e802fc
--- /dev/null
+++ b/dev-python/keystoneauth/keystoneauth-2.4.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="This package contains tools for authenticating to an OpenStack-based cloud."
+HOMEPAGE="https://github.com/openstack/keystoneauth"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}1/${PN}1-${PV}.tar.gz"
+S="${WORKDIR}/${PN}1-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-1.6[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="${CDEPEND}
+ >=dev-python/iso8601-0.1.9[${PYTHON_USEDEP}]
+ >=dev-python/positional-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.8.1[${PYTHON_USEDEP}]
+ !~dev-python/requests-2.9.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.5.0[${PYTHON_USEDEP}]"