summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2017-08-27 19:17:55 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2017-08-27 19:47:01 -0500
commitb7eb3a6705f49e5ce686b6d6c77393ef155a02bb (patch)
tree25de604e55f47907a45eaf170000bf94d3fd990a /dev-python/keystoneauth
parentdev-python/requests: 2.18.2 bup (diff)
downloadgentoo-b7eb3a6705f49e5ce686b6d6c77393ef155a02bb.tar.gz
gentoo-b7eb3a6705f49e5ce686b6d6c77393ef155a02bb.tar.bz2
gentoo-b7eb3a6705f49e5ce686b6d6c77393ef155a02bb.zip
dev-python/keystoneauth: 3.1.0 bup
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'dev-python/keystoneauth')
-rw-r--r--dev-python/keystoneauth/Manifest1
-rw-r--r--dev-python/keystoneauth/keystoneauth-3.1.0.ebuild28
2 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/keystoneauth/Manifest b/dev-python/keystoneauth/Manifest
index 85e30ba3e891..6d3ef931952e 100644
--- a/dev-python/keystoneauth/Manifest
+++ b/dev-python/keystoneauth/Manifest
@@ -3,3 +3,4 @@ DIST keystoneauth1-2.18.0.tar.gz 184966 SHA256 075a9ca7a8877c5885fa2487699015e45
DIST keystoneauth1-2.20.0.tar.gz 187746 SHA256 6bb45250f2e716302f9572f3f5440baf4b7339a93e0ea33c38ac501294da9b2e SHA512 43d949e46f743905e6987df9f923f222bf4b5622fd395c66da4dbed626d3ba80787a9e77340caf53018c7e277366851ffbfac0812c0f75f6c9c4755eebd852fb WHIRLPOOL a7c2f38a99e69d5885f8420f1a0c06249630487f9c833015366bc90ce6c372a0aac2c2bb8104610fa0a5e9fd21d4a60ecb1fd5851c77d1787845d2a7780680ea
DIST keystoneauth1-2.4.1.tar.gz 150586 SHA256 61a2f4cf374b55f10a0d8250a532ccb93dff2ea81994ced15b2a34af055d4e78 SHA512 f9e8fcea7b23001b907d643d5bf67fc4779c8729cca213b3240ef988eda9de1212b15c2031f6fd8b431aafac85e773346eda71e0b414fe967728611b6817fb05 WHIRLPOOL 42644ede5c0db10ffe77ef106d78764dcb49d455dbc09e3660160b9d7a9eb3453118f6777469f9779e2fca34eb9e09cf3ef759f2f27cc38b8dca8520b9febd43
DIST keystoneauth1-2.4.2.tar.gz 151213 SHA256 c8be35bdf5c773c385a0b9b773ec55c44c9c3ea7587179d15b2d4352ae2cbe57 SHA512 dd3b0907c554606489081b970ad248efe52aa6593cb8584ac1d4e3b05075b6a60b8c5f159c00f5668eb0938dbed655e7135ac9b7d3d6017f2f280f69b9080122 WHIRLPOOL b0b79a431b90aa78852a2a76c5f3a72081975c8f5b7e2174ded010c560f3ec205ae702722cd32cea33876f478009400e626b8a7ef750bdb15b9b7a93d7b71189
+DIST keystoneauth1-3.1.0.tar.gz 217744 SHA256 e5abfa8bbe866d52ca56afbe528d15214a60033cc1dc9804478cae7424f0f8fb SHA512 3214e08cf449a0eff35eff0400542cbb9e46051095d7955593fec89c4ba31062677f434c70c40037db213fa0e0db15c66d1058e0eca35b1d214967f7fa3fcf14 WHIRLPOOL ab7888dfb85ac6b5e2e0acf35943cad714caae156d19619588ef2fe9532d03c354ba0bd6cd9753654f394f268990eea1915847b1ab6b5a9b4aa9c930bc280e65
diff --git a/dev-python/keystoneauth/keystoneauth-3.1.0.ebuild b/dev-python/keystoneauth/keystoneauth-3.1.0.ebuild
new file mode 100644
index 000000000000..c9f5bf8a83f0
--- /dev/null
+++ b/dev-python/keystoneauth/keystoneauth-3.1.0.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_4 python3_5 )
+
+inherit distutils-r1
+
+DESCRIPTION="This package contains tools for authenticating to an OpenStack-based cloud."
+HOMEPAGE="https://github.com/openstack/keystoneauth"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}1/${PN}1-${PV}.tar.gz"
+S="${WORKDIR}/${PN}1-${PV}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+CDEPEND=">=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ ${CDEPEND}"
+RDEPEND="${CDEPEND}
+ >=dev-python/iso8601-0.1.11[${PYTHON_USEDEP}]
+ >=dev-python/positional-1.1.1[${PYTHON_USEDEP}]
+ >=dev-python/requests-2.14.2[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=dev-python/stevedore-1.20.0[${PYTHON_USEDEP}]"