summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/kid
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/kid')
-rw-r--r--dev-python/kid/Manifest1
-rw-r--r--dev-python/kid/kid-0.9.6-r1.ebuild40
-rw-r--r--dev-python/kid/metadata.xml10
3 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/kid/Manifest b/dev-python/kid/Manifest
new file mode 100644
index 000000000000..97af099e5505
--- /dev/null
+++ b/dev-python/kid/Manifest
@@ -0,0 +1 @@
+DIST kid-0.9.6.tar.gz 268602 SHA256 d4c84b3de0a0584b33db489e5dde82f9c2c8832f40dad0413bce309e16813ab9 SHA512 56f87f5fdb9d692ced4b19c13705ee872058279084f49efd2e2515c28240e36833c7dfbecf084f504d6fef45f2cc60185decf0c9f18517d255ba469486aa3ae8 WHIRLPOOL 3dd2203c0b9c1e9a065729a2d8fe73cb5525ec99fcae73f3541cba7c1182355241057d9996eaab4b2d3fa91566c644db7a43cba61b3ed1c9ce15acf5ca97b4a5
diff --git a/dev-python/kid/kid-0.9.6-r1.ebuild b/dev-python/kid/kid-0.9.6-r1.ebuild
new file mode 100644
index 000000000000..2bec8d682429
--- /dev/null
+++ b/dev-python/kid/kid-0.9.6-r1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A simple and Pythonic XML template language"
+HOMEPAGE="http://www.kid-templating.org/ http://pypi.python.org/pypi/kid"
+SRC_URI="http://www.kid-templating.org/dist/${PV}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ia64 x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE="doc examples test"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/docutils[${PYTHON_USEDEP}] )"
+
+DOCS=( README doc/{guide.txt,index.txt,notes.txt} )
+
+python_compile_all() {
+ use doc && emake -C doc
+}
+
+python_test() {
+ py.test -xl || die
+}
+
+python_install_all() {
+# dobin bin/*
+
+ use doc && local HTML_DOCS=( doc/html/. )
+ use examples && local EXAMPLES=( examples/. )
+
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/kid/metadata.xml b/dev-python/kid/metadata.xml
new file mode 100644
index 000000000000..4813d7da1baf
--- /dev/null
+++ b/dev-python/kid/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>python</herd>
+<longdescription>
+Kid is a simple template language for XML based vocabularies written
+in Python. The syntax was inspired by a number of existing template
+languages, namely XSLT, TAL, and PHP.
+</longdescription>
+</pkgmetadata>