summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-06-21 19:09:34 +0200
committerMichał Górny <mgorny@gentoo.org>2022-06-21 19:09:34 +0200
commitc6b82c6f9ba271ed07fcf6d98dbfed136a171f9a (patch)
treeee6a741251ccaeb495c9cd0bd5fe5c14c89e8520 /dev-python/kiwisolver
parentdev-utils/ebuildtester: Version bump to v41 (diff)
downloadgentoo-c6b82c6f9ba271ed07fcf6d98dbfed136a171f9a.tar.gz
gentoo-c6b82c6f9ba271ed07fcf6d98dbfed136a171f9a.tar.bz2
gentoo-c6b82c6f9ba271ed07fcf6d98dbfed136a171f9a.zip
dev-python/kiwisolver: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/kiwisolver')
-rw-r--r--dev-python/kiwisolver/Manifest1
-rw-r--r--dev-python/kiwisolver/files/kiwisolver-1.4.2-python311.patch31
-rw-r--r--dev-python/kiwisolver/kiwisolver-1.4.2.ebuild41
3 files changed, 0 insertions, 73 deletions
diff --git a/dev-python/kiwisolver/Manifest b/dev-python/kiwisolver/Manifest
index cf788ddcd3e5..df3d7c5b6935 100644
--- a/dev-python/kiwisolver/Manifest
+++ b/dev-python/kiwisolver/Manifest
@@ -1,2 +1 @@
-DIST kiwi-1.4.2.tar.gz 91150 BLAKE2B 8441d52267b3b436d9f05baabbd3beafc51d2f257fc982f1cf90b6296ccdbc24511de6b55b6201eb1df37ec9487282cc40142e9083cf4c1e925976a098927e1a SHA512 e7726ac7985bea1020fd3a26bf54b941acfffffb1f47b462c74f9829c5a89e7abd0732b5a11685b20d6a17ac9625178c68ea71052e852f91491a308d07111b01
DIST kiwi-1.4.3.gh.tar.gz 91238 BLAKE2B bdd6164eb428e6769ae7de2a8e689a3944e13e81aef9a839d9f68459deb7e7c0840b0eb59e70932e5c1d835444c515c8cb66fa47f40d8fc6244de47852be57d6 SHA512 04205555da46e772f2d25a481c4d966dc7bab8a541434a7c183e1b4f41ccd6e06aec564f2a95dae649585d337c1bf818a7cf24727460ad14669a3b3d74c74274
diff --git a/dev-python/kiwisolver/files/kiwisolver-1.4.2-python311.patch b/dev-python/kiwisolver/files/kiwisolver-1.4.2-python311.patch
deleted file mode 100644
index a03af53a0280..000000000000
--- a/dev-python/kiwisolver/files/kiwisolver-1.4.2-python311.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-https://github.com/nucleic/kiwi/commit/f14059f532d6b5c6b505d9803b36a77b75546b18.patch
-https://bugs.gentoo.org/849563
-
-From f14059f532d6b5c6b505d9803b36a77b75546b18 Mon Sep 17 00:00:00 2001
-From: Matthieu Dartiailh <m.dartiailh@gmail.com>
-Date: Fri, 3 Jun 2022 09:11:18 +0200
-Subject: [PATCH] py: use nullptr instead of 0 in PyTuple_SET_ITEM
-
---- a/py/src/symbolics.h
-+++ b/py/src/symbolics.h
-@@ -123,7 +123,7 @@ PyObject* BinaryMul::operator()( Expression* first, double second )
- return 0;
- Py_ssize_t end = PyTuple_GET_SIZE( first->terms );
- for( Py_ssize_t i = 0; i < end; ++i ) // memset 0 for safe error return
-- PyTuple_SET_ITEM( terms.get(), i, 0 );
-+ PyTuple_SET_ITEM( terms.get(), i, nullptr );
- for( Py_ssize_t i = 0; i < end; ++i )
- {
- PyObject* item = PyTuple_GET_ITEM( first->terms, i );
---- a/py/src/util.h
-+++ b/py/src/util.h
-@@ -117,7 +117,7 @@ make_terms( const std::map<PyObject*, double>& coeffs )
- return 0;
- Py_ssize_t size = PyTuple_GET_SIZE( terms.get() );
- for( Py_ssize_t i = 0; i < size; ++i ) // zero tuple for safe early return
-- PyTuple_SET_ITEM( terms.get(), i, 0 );
-+ PyTuple_SET_ITEM( terms.get(), i, nullptr );
- Py_ssize_t i = 0;
- iter_t it = coeffs.begin();
- iter_t end = coeffs.end();
-
diff --git a/dev-python/kiwisolver/kiwisolver-1.4.2.ebuild b/dev-python/kiwisolver/kiwisolver-1.4.2.ebuild
deleted file mode 100644
index e29fa7eee534..000000000000
--- a/dev-python/kiwisolver/kiwisolver-1.4.2.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..11} )
-
-inherit distutils-r1
-
-MY_P=kiwi-${PV}
-DESCRIPTION="An efficient C++ implementation of the Cassowary constraint solving algorithm"
-HOMEPAGE="https://github.com/nucleic/kiwi/"
-SRC_URI="
- https://github.com/nucleic/kiwi/archive/${PV}.tar.gz -> ${MY_P}.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="Clear-BSD"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ppc ppc64 ~riscv ~s390 sparc x86"
-
-COMMON_DEPEND="
- >=dev-python/cppy-1.2.0[${PYTHON_USEDEP}]
-"
-
-RDEPEND="
- ${COMMON_DEPEND}
-"
-BDEPEND="
- ${COMMON_DEPEND}
- >=dev-python/setuptools_scm-3.4.3[${PYTHON_USEDEP}]
-"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-1.4.2-python311.patch
-)
-
-distutils_enable_tests pytest
-
-export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}