summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZac Medico <zachary.medico@sony.com>2019-06-28 17:05:46 -0700
committerZac Medico <zmedico@gentoo.org>2019-06-30 14:57:07 -0700
commit1bebe34a7bbb915ecc70fc9b73ab0deb40ead6cb (patch)
treeca9519d4cde152c2fc6b3dd61e5ebeaf26654caf /dev-python/kombu/kombu-4.6.3.ebuild
parentdev-python/celery: Bump to version 4.3.0 (diff)
downloadgentoo-1bebe34a7bbb915ecc70fc9b73ab0deb40ead6cb.tar.gz
gentoo-1bebe34a7bbb915ecc70fc9b73ab0deb40ead6cb.tar.bz2
gentoo-1bebe34a7bbb915ecc70fc9b73ab0deb40ead6cb.zip
dev-python/kombu: Bump to version 4.6.3
Note that this ebuild drops python2_7 from PYTHON_COMPAT because it was also dropped from the dev-python/pyro-4.76 ebuild. Closes: https://bugs.gentoo.org/688728 Package-Manager: Portage-2.3.67, Repoman-2.3.16 Signed-off-by: Zac Medico <zmedico@gentoo.org>
Diffstat (limited to 'dev-python/kombu/kombu-4.6.3.ebuild')
-rw-r--r--dev-python/kombu/kombu-4.6.3.ebuild78
1 files changed, 78 insertions, 0 deletions
diff --git a/dev-python/kombu/kombu-4.6.3.ebuild b/dev-python/kombu/kombu-4.6.3.ebuild
new file mode 100644
index 000000000000..24fd55a80594
--- /dev/null
+++ b/dev-python/kombu/kombu-4.6.3.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="AMQP Messaging Framework for Python"
+HOMEPAGE="https://pypi.org/project/kombu/ https://github.com/celery/kombu"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE="doc examples mongodb msgpack redis sqs test yaml"
+
+# zookeeper backend support possible via dev-python/kazoo
+RDEPEND="
+ >=dev-python/py-amqp-2.5.0[${PYTHON_USEDEP}]
+ <dev-python/py-amqp-3.0[${PYTHON_USEDEP}]
+ >=dev-python/pyro-4.76:4[${PYTHON_USEDEP}]
+ sqs? ( >=dev-python/boto3-1.4.4[${PYTHON_USEDEP}] )
+ msgpack? ( >=dev-python/msgpack-0.3.0[${PYTHON_USEDEP}] )
+ mongodb? ( >=dev-python/pymongo-3.0.2[${PYTHON_USEDEP}] )
+ redis? ( >=dev-python/redis-py-3.2.0[${PYTHON_USEDEP}] )
+ yaml? ( >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}] )"
+# Fix to https://github.com/celery/kombu/issues/474 obliges dev-python/pymongo to >=-3.0.2
+DEPEND="${RDEPEND}
+ >=dev-python/setuptools-20.6.7[${PYTHON_USEDEP}]
+ test? (
+ >=dev-python/case-1.5.2[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/unittest2[${PYTHON_USEDEP}] )
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ >=dev-python/sphinx_celery-1.1[${PYTHON_USEDEP}] )"
+
+# kazoo is optional for tests.
+# Refrain for now, no established demand for it from users
+
+# Req'd for test phase
+DISTUTILS_IN_SOURCE_BUILD=1
+
+PATCHES=(
+)
+
+python_prepare_all() {
+ # AttributeError: test_Etcd instance has no attribute 'patch'
+ rm t/unit/transport/test_etcd.py || die
+ # allow use of new (renamed) msgpack
+ sed -i '/msgpack/d' requirements/extras/msgpack.txt || die
+ # pytest-sugar is not packaged
+ sed -i '/pytest-sugar/d' requirements/test.txt || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ # Doc build misses and skips only content re librabbitmq which is not in portage
+ if use doc; then
+ emake -C docs html || die "kombu docs failed installation"
+ fi
+}
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ if use examples; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ docinto examples
+ dodoc -r examples/.
+ fi
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}