summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDenis Efremov <efremov@linux.com>2021-02-16 15:22:32 +0300
committerJoonas Niilola <juippis@gentoo.org>2021-03-19 09:43:20 +0200
commit41f5555ab1b1d608203b91a96d900ed22be7a4cb (patch)
tree6aeb94f13a4d487621f7a464c31de26192a423c4 /dev-python/lark-parser
parentdev-python/pydocstyle: Bump to 6.0.0 (diff)
downloadgentoo-41f5555ab1b1d608203b91a96d900ed22be7a4cb.tar.gz
gentoo-41f5555ab1b1d608203b91a96d900ed22be7a4cb.tar.bz2
gentoo-41f5555ab1b1d608203b91a96d900ed22be7a4cb.zip
dev-python/lark-parser: add 0.11.2
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Denis Efremov <efremov@linux.com> Closes: https://github.com/gentoo/gentoo/pull/19486 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'dev-python/lark-parser')
-rw-r--r--dev-python/lark-parser/Manifest1
-rw-r--r--dev-python/lark-parser/lark-parser-0.11.2.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/lark-parser/Manifest b/dev-python/lark-parser/Manifest
index 48eab849127e..66ebacd3e69c 100644
--- a/dev-python/lark-parser/Manifest
+++ b/dev-python/lark-parser/Manifest
@@ -1 +1,2 @@
+DIST lark-parser-0.11.2.tar.gz 225851 BLAKE2B b4fec8701287237442d8fd3b2519f75f70f153a0d9deba8b39ba3317df358fe1ddda738f320ff689a7a8965ab157fefea7eb121ea980c6a6d8ca1b42d63941c9 SHA512 277be4e6d56d8e2747df434518d6d7918c149a67c3f6af3f978858be86f3fae9248989823c2429dbdff4a1c1615753607f5487fd9d6705cfafec698cb9d47e4b
DIST lark-parser-0.7.8.tar.gz 276204 BLAKE2B c2d103f41b7b6ccb988c5935c53e422d495980c1d64cba125e9d27b9b7bf03c0864904e6c2c6b40ec56e8975a8051f1a18c9da126d02fe149dc3684ea7d41c30 SHA512 52eed1a5f26fa7ba79820298a8f6f7594b2351797abdaf8fd96f76e15a11711805955e055164ce287f7204edf3d19116562795cf56db464b4f2f15e40e1da561
diff --git a/dev-python/lark-parser/lark-parser-0.11.2.ebuild b/dev-python/lark-parser/lark-parser-0.11.2.ebuild
new file mode 100644
index 000000000000..f13dafb312ee
--- /dev/null
+++ b/dev-python/lark-parser/lark-parser-0.11.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=bdepend
+
+inherit distutils-r1
+
+DESCRIPTION="Python module to propose a modern general-purpose parsing library for Python"
+HOMEPAGE="https://github.com/lark-parser/lark"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/regex[${PYTHON_USEDEP}]
+ dev-python/js2py[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ "${EPYTHON}" -m tests || die "Tests fail with ${EPYTHON}"
+}