summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2021-09-09 20:23:16 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2021-09-09 21:30:46 +0300
commit8d315c67d975f907f34a590b2251225ec935432f (patch)
tree0b8a0337aae0365a584b84231e56b2a7eb9fdd4d /dev-python/lazr-config
parentdev-python/lazr-delegates: mark ALLARCHES (diff)
downloadgentoo-8d315c67d975f907f34a590b2251225ec935432f.tar.gz
gentoo-8d315c67d975f907f34a590b2251225ec935432f.tar.bz2
gentoo-8d315c67d975f907f34a590b2251225ec935432f.zip
dev-python/lazr-config: enable py3.10, EAPI=8, fix pth file install
Closes: https://bugs.gentoo.org/798084 Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/lazr-config')
-rw-r--r--dev-python/lazr-config/lazr-config-2.2.3.ebuild16
1 files changed, 13 insertions, 3 deletions
diff --git a/dev-python/lazr-config/lazr-config-2.2.3.ebuild b/dev-python/lazr-config/lazr-config-2.2.3.ebuild
index 51ec50017b8e..0c5ea95d8e05 100644
--- a/dev-python/lazr-config/lazr-config-2.2.3.ebuild
+++ b/dev-python/lazr-config/lazr-config-2.2.3.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{8..10} )
DISTUTILS_USE_SETUPTOOLS=rdepend
inherit distutils-r1
@@ -20,5 +20,15 @@ SLOT="0"
KEYWORDS="~amd64 ~x86"
RDEPEND="
+ dev-python/lazr-delegates[${PYTHON_USEDEP}]
+ dev-python/namespace-lazr[${PYTHON_USEDEP}]
dev-python/zope-interface[${PYTHON_USEDEP}]
- dev-python/lazr-delegates[${PYTHON_USEDEP}]"
+"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ find "${ED}" -name '*.pth' -delete || die
+}