summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-09-10 09:57:20 +0200
committerJustin Lecher <jlec@gentoo.org>2015-09-10 09:59:42 +0200
commit292383da43eb30cbac4fe496103f83c8c5bb5399 (patch)
treeb564ed6c8d174a666b23c201ebe6ce52c9a3002f /dev-python/ldap3/ldap3-0.9.9.ebuild
parentdev-python/bpython: Drop unnecessary restriction on curtsies dep (diff)
downloadgentoo-292383da43eb30cbac4fe496103f83c8c5bb5399.tar.gz
gentoo-292383da43eb30cbac4fe496103f83c8c5bb5399.tar.bz2
gentoo-292383da43eb30cbac4fe496103f83c8c5bb5399.zip
dev-python/ldap3: Version Bump
Package-Manager: portage-2.2.20.1 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/ldap3/ldap3-0.9.9.ebuild')
-rw-r--r--dev-python/ldap3/ldap3-0.9.9.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/ldap3/ldap3-0.9.9.ebuild b/dev-python/ldap3/ldap3-0.9.9.ebuild
new file mode 100644
index 000000000000..700d8ef8deaf
--- /dev/null
+++ b/dev-python/ldap3/ldap3-0.9.9.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A strictly RFC 4511 conforming LDAP V3 pure Python client"
+HOMEPAGE="https://github.com/cannatag/ldap3 https://pypi.python.org/pypi/ldap3"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND=">=dev-python/pyasn1-0.1.8[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+ "
+
+python_test() {
+ cd "${BUILD_DIR}" || die
+ nosetests -v -s test || die
+}