summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-12-07 10:10:58 +0100
committerJustin Lecher <jlec@gentoo.org>2015-12-07 10:11:04 +0100
commit3abfdf4ae2e6847ed4cf97097f125c48ca889a16 (patch)
tree58b0fe07d2629143a0e7158e8b6e6090f2747459 /dev-python/ldap3/ldap3-1.0.1.ebuild
parentdev-python/py-amqp: Version Bump (diff)
downloadgentoo-3abfdf4ae2e6847ed4cf97097f125c48ca889a16.tar.gz
gentoo-3abfdf4ae2e6847ed4cf97097f125c48ca889a16.tar.bz2
gentoo-3abfdf4ae2e6847ed4cf97097f125c48ca889a16.zip
dev-python/ldap3: Version Bump
Package-Manager: portage-2.2.26 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/ldap3/ldap3-1.0.1.ebuild')
-rw-r--r--dev-python/ldap3/ldap3-1.0.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/ldap3/ldap3-1.0.1.ebuild b/dev-python/ldap3/ldap3-1.0.1.ebuild
new file mode 100644
index 000000000000..700d8ef8deaf
--- /dev/null
+++ b/dev-python/ldap3/ldap3-1.0.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A strictly RFC 4511 conforming LDAP V3 pure Python client"
+HOMEPAGE="https://github.com/cannatag/ldap3 https://pypi.python.org/pypi/ldap3"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND=">=dev-python/pyasn1-0.1.8[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )
+ "
+
+python_test() {
+ cd "${BUILD_DIR}" || die
+ nosetests -v -s test || die
+}