summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Thode <prometheanfire@gentoo.org>2019-03-13 11:29:27 -0500
committerMatthew Thode <prometheanfire@gentoo.org>2019-03-13 11:44:38 -0500
commitc69a8f747dd17e83a9fc121fdd154b5c07060bc3 (patch)
tree3d57e3ef06d5fe3a933687e4916cf3062645fb21 /dev-python/ldappool/ldappool-2.3.1.ebuild
parentdev-python/os-brick: 2.5.5 bump (diff)
downloadgentoo-c69a8f747dd17e83a9fc121fdd154b5c07060bc3.tar.gz
gentoo-c69a8f747dd17e83a9fc121fdd154b5c07060bc3.tar.bz2
gentoo-c69a8f747dd17e83a9fc121fdd154b5c07060bc3.zip
dev-python/ldappool: 2.3.1 bump
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthew Thode <prometheanfire@gentoo.org>
Diffstat (limited to 'dev-python/ldappool/ldappool-2.3.1.ebuild')
-rw-r--r--dev-python/ldappool/ldappool-2.3.1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/ldappool/ldappool-2.3.1.ebuild b/dev-python/ldappool/ldappool-2.3.1.ebuild
new file mode 100644
index 000000000000..9a2f70feaab0
--- /dev/null
+++ b/dev-python/ldappool/ldappool-2.3.1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A connection pool for python-ldap"
+HOMEPAGE="https://launchpad.net/oslo"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+IUSE=""
+
+DEPEND="
+ >=dev-python/pbr-2.0.0[${PYTHON_USEDEP}]
+ !~dev-python/pbr-2.1.0[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+RDEPEND="
+ >=dev-python/python-ldap-3.0.0[${PYTHON_USEDEP}]
+"