summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-04 07:27:02 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-04 07:31:25 +0100
commit5756e42f19ff6be22869ecf3dab2cb2565c5dde9 (patch)
treef0358be5c500cd6053dc4ab51133ab2d4d0b9d09 /dev-python/leechcorepyc
parentdev-python/pypdf: Bump to 4.1.0 (diff)
downloadgentoo-5756e42f19ff6be22869ecf3dab2cb2565c5dde9.tar.gz
gentoo-5756e42f19ff6be22869ecf3dab2cb2565c5dde9.tar.bz2
gentoo-5756e42f19ff6be22869ecf3dab2cb2565c5dde9.zip
dev-python/leechcorepyc: Bump to 2.17.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/leechcorepyc')
-rw-r--r--dev-python/leechcorepyc/Manifest1
-rw-r--r--dev-python/leechcorepyc/leechcorepyc-2.17.2.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/leechcorepyc/Manifest b/dev-python/leechcorepyc/Manifest
index 186fdd4e84d7..904d462f6c2f 100644
--- a/dev-python/leechcorepyc/Manifest
+++ b/dev-python/leechcorepyc/Manifest
@@ -1,2 +1,3 @@
DIST leechcorepyc-2.16.9.tar.gz 178656 BLAKE2B 76cefea2d8c30c88ae649da6c95f420b366e6b7ec8a44339cda6bd65b890b02196ff19d3b7d8218c87a73256e079fdd51dcb0499934fef0145e4a404376be7de SHA512 5a5455d0401177d2ae4f6b22a0dbf1f4ddce3458edb4cea04c8a127a6baa7083c83ba79d3d236a6cec15e8a1c05c4a8c747d7053b451dbed9b6a8defa17ec288
DIST leechcorepyc-2.17.0.tar.gz 179198 BLAKE2B b811e924687e67d394a5271a88ad01e0f9d528176e50baecc9f471c17cc016f11e02e05c4ac0b04277f6828aa2c1c4ff39d56065d6f95a5f0c1d909b0b448b2f SHA512 91cf73c62af104f83bd4d4926633ceb702027c97137c351e4d6d8518a4c8c467031153127e85058a9b451e33f370257dd3aa461f0eab643fb8b48a62827ed436
+DIST leechcorepyc-2.17.2.tar.gz 179233 BLAKE2B 7b5b472c829e897f089f7b0a1de941b22e54ec1f740b837e5f0c291af656601411acb20e22034322b1618dab64a5a9aa34f78115c91fd11b1fdeb7663ff4c422 SHA512 f51ca93791ccbe0bcb8fc298ace7ee6757a26fc8052380fdd101dfc5686942cb6243fc8aca06f0c1f14faf076dd0055cf653e6ad253c6460cd65fac4a5b094a9
diff --git a/dev-python/leechcorepyc/leechcorepyc-2.17.2.ebuild b/dev-python/leechcorepyc/leechcorepyc-2.17.2.ebuild
new file mode 100644
index 000000000000..594aa6daeab7
--- /dev/null
+++ b/dev-python/leechcorepyc/leechcorepyc-2.17.2.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 toolchain-funcs pypi
+
+DESCRIPTION="Python binding for LeechCore Physical Memory Acquisition Library"
+HOMEPAGE="https://github.com/ufrisk/LeechCore"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# leechcorepyc ships with a bundled version of the LeechCore library. So we
+# don't depend on the library here. But we must be aware this module doesn't
+# use the system library.
+DEPEND="virtual/libusb:="
+RDEPEND="${DEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.16.9-respect-CC.patch"
+)
+
+src_prepare() {
+ default
+
+ # Avoid redefining _FORTIFY_SOURCE. See #893824, #906715.
+ sed -i -e 's/ -D_FORTIFY_SOURCE=2 / /g' leechcore/Makefile || die
+}
+
+src_configure() {
+ tc-export CC
+
+ distutils-r1_src_configure
+}