summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-06-12 10:35:54 +0200
committerPatrick Lauer <patrick@gentoo.org>2016-06-12 11:03:59 +0200
commite6428253b82e46a72ca3d17c6835f7e329709a9c (patch)
tree0504e06c99fb93972c4886c9532ccd355832777a /dev-python/lesscpy/lesscpy-0.11.1.ebuild
parentdev-python/hypothesis: Bump (diff)
downloadgentoo-e6428253b82e46a72ca3d17c6835f7e329709a9c.tar.gz
gentoo-e6428253b82e46a72ca3d17c6835f7e329709a9c.tar.bz2
gentoo-e6428253b82e46a72ca3d17c6835f7e329709a9c.zip
dev-python/lesscpy: Bump
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'dev-python/lesscpy/lesscpy-0.11.1.ebuild')
-rw-r--r--dev-python/lesscpy/lesscpy-0.11.1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/lesscpy/lesscpy-0.11.1.ebuild b/dev-python/lesscpy/lesscpy-0.11.1.ebuild
new file mode 100644
index 000000000000..9455ae1ea7c9
--- /dev/null
+++ b/dev-python/lesscpy/lesscpy-0.11.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} )
+
+inherit distutils-r1
+
+# incomplete tarball
+RESTRICT="test"
+
+DESCRIPTION="A compiler written in Python for the LESS language"
+HOMEPAGE="https://pypi.python.org/pypi/lesscpy"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/ply[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+
+python_test() {
+ # https://github.com/lesscpy/lesscpy/issues/74
+ esetup.py test
+ # This is equally effective
+ # nosetests -v || die "tests failed under ${EPYTHON}"
+}