summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/lesscpy
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/lesscpy')
-rw-r--r--dev-python/lesscpy/Manifest2
-rw-r--r--dev-python/lesscpy/lesscpy-0.10.2.ebuild28
-rw-r--r--dev-python/lesscpy/lesscpy-0.9j.ebuild24
-rw-r--r--dev-python/lesscpy/metadata.xml15
4 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/lesscpy/Manifest b/dev-python/lesscpy/Manifest
new file mode 100644
index 000000000000..e84ec02b436d
--- /dev/null
+++ b/dev-python/lesscpy/Manifest
@@ -0,0 +1,2 @@
+DIST lesscpy-0.10.2.tar.gz 159031 SHA256 ccad1ad2a89ced1875c5ca4e16e5478b791d31fb187fe29f1541859318ed9055 SHA512 9da17a3f5819566c081b94be016ff53a51f8251d7ab55e32fe469eb298a65378fb0db22b34abcf0192b2ba7ad092c2c41dc4a56b01403e1a8e43b107e4fd16bc WHIRLPOOL 600a744534fa284e7978340f773ebb2addeeac4f79ae7a9442271d482f0e5950ac9abe9f7d5f0079e44a5ed446fd710cd3ec3b4ab3c827dc4dd311c6591edebd
+DIST lesscpy-0.9j.tar.gz 32061 SHA256 fa01d435a1ab3abafba683519bdc7aca5e19399e96225e1a8bc1d660b566364d SHA512 9063b89a1ca8dc8424b3b1989bdf7c31de74e26ab8ab5ede1664f53d1ff1946308d9add65236cd5fabc58efcaf1cb5789fa73f0775a83cb70ea9a73d25207a73 WHIRLPOOL 3e885dc03138a2b693c94af775e4386bc8c2bcecb8b6202a5f80ec5b8435798cb0d06934d7e9eb39e0a54c9861c009a673d6ee7990050f1164e239157047140a
diff --git a/dev-python/lesscpy/lesscpy-0.10.2.ebuild b/dev-python/lesscpy/lesscpy-0.10.2.ebuild
new file mode 100644
index 000000000000..b88fccbc3a9b
--- /dev/null
+++ b/dev-python/lesscpy/lesscpy-0.10.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+inherit distutils-r1
+
+DESCRIPTION="A compiler written in Python for the LESS language"
+HOMEPAGE="https://pypi.python.org/pypi/lesscpy"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/ply[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+
+python_test() {
+ # https://github.com/lesscpy/lesscpy/issues/74
+ esetup.py test
+ # This is equally effective
+ # nosetests -v || die "tests failed under ${EPYTHON}"
+}
diff --git a/dev-python/lesscpy/lesscpy-0.9j.ebuild b/dev-python/lesscpy/lesscpy-0.9j.ebuild
new file mode 100644
index 000000000000..5ed205722884
--- /dev/null
+++ b/dev-python/lesscpy/lesscpy-0.9j.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A compiler written in Python for the LESS language"
+HOMEPAGE="https://pypi.python.org/pypi/lesscpy"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/ply[${PYTHON_USEDEP}]"
+
+python_test() {
+ ${PYTHON} lesscpy/test/__main__.py || die "test failed under ${EPYTHON}"
+}
diff --git a/dev-python/lesscpy/metadata.xml b/dev-python/lesscpy/metadata.xml
new file mode 100644
index 000000000000..45e0253a5f96
--- /dev/null
+++ b/dev-python/lesscpy/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <longdescription lang="en">
+ A compiler written in Python for the LESS language.
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">lesscpy</remote-id>
+ </upstream>
+</pkgmetadata>