summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2018-03-31 23:16:14 +0200
committerPatrice Clement <monsieurp@gentoo.org>2018-04-01 23:53:22 +0200
commit9d2a2f3a4b75df4de7a52490ec618c57ad9fdfb9 (patch)
treeb9d7e529559c2e8908d71a12d3a9a49e7086f124 /dev-python/lesscpy
parentmedia-libs/libdvbpsi: stable 1.3.1 for ppc64, bug #648058 (diff)
downloadgentoo-9d2a2f3a4b75df4de7a52490ec618c57ad9fdfb9.tar.gz
gentoo-9d2a2f3a4b75df4de7a52490ec618c57ad9fdfb9.tar.bz2
gentoo-9d2a2f3a4b75df4de7a52490ec618c57ad9fdfb9.zip
dev-python/lesscpy: version bump.
Closes: https://bugs.gentoo.org/634018 Package-Manager: Portage-2.3.19, Repoman-2.3.6
Diffstat (limited to 'dev-python/lesscpy')
-rw-r--r--dev-python/lesscpy/Manifest1
-rw-r--r--dev-python/lesscpy/lesscpy-0.13.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/lesscpy/Manifest b/dev-python/lesscpy/Manifest
index f3cf5e7972d9..8dca9a97d1ce 100644
--- a/dev-python/lesscpy/Manifest
+++ b/dev-python/lesscpy/Manifest
@@ -1,2 +1,3 @@
DIST lesscpy-0.11.1.tar.gz 159706 BLAKE2B 4f664d7e6d6edc0fea6db8d9b664703e408cbfccd666760ce1f394746696c61b28755668c7fe0d5ef374735e1ab6514532e2992d2d0c6292ef88861b25636225 SHA512 2cf4e8c3a46cf5e9a7f1dd80f613550fa0e857a8acf9d33d9da2f7a90e1b264bbc18a427668f152ff136b438b19866f016dec91794c721b98ec2f2456dc504e3
+DIST lesscpy-0.13.0.tar.gz 157854 BLAKE2B 2a06827233e5142249298c75d323ffaed2cf497f5ddf86023e65235417f3fb970e66a6b112e9eeb38f24868ab98a6d4b9bcb0cf8a53a2121fff44098fdde459a SHA512 227db8212a386b06f288140d09b7505ae43bc6221396fa2d154a6d7f0831cf1ff005d9818fd85fb3804103b725b60827cf56a29930c2de928546ab0dcf3d5877
DIST lesscpy-0.9j.tar.gz 32061 BLAKE2B 95edffd8cfe958d966062fa58c041ebf411d5f771d48cc1da9f868c35094bb5b465449616e994690c972414cc188c9343ae29839df9fa57711e4575a42f927fc SHA512 9063b89a1ca8dc8424b3b1989bdf7c31de74e26ab8ab5ede1664f53d1ff1946308d9add65236cd5fabc58efcaf1cb5789fa73f0775a83cb70ea9a73d25207a73
diff --git a/dev-python/lesscpy/lesscpy-0.13.0.ebuild b/dev-python/lesscpy/lesscpy-0.13.0.ebuild
new file mode 100644
index 000000000000..fe7989aca099
--- /dev/null
+++ b/dev-python/lesscpy/lesscpy-0.13.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+# incomplete tarball
+RESTRICT="test"
+
+DESCRIPTION="A compiler written in Python for the LESS language"
+HOMEPAGE="https://pypi.python.org/pypi/lesscpy"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-python/ply[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+
+python_test() {
+ # https://github.com/lesscpy/lesscpy/issues/74
+ esetup.py test
+ # This is equally effective
+ # nosetests -v || die "tests failed under ${EPYTHON}"
+}