summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2016-01-12 10:01:21 -0800
committerPatrick McLean <chutzpah@gentoo.org>2016-01-12 10:01:21 -0800
commit495db5935035929b44673c4b17e1d8f094ba4fbe (patch)
treed83e62192bbcfe7d02336a13290288442ee07b1a /dev-python/libnacl/libnacl-1.4.4.ebuild
parentsys-libs/ldb: resolve automagic header usage on libbsd by RDEPENDing on it (diff)
downloadgentoo-495db5935035929b44673c4b17e1d8f094ba4fbe.tar.gz
gentoo-495db5935035929b44673c4b17e1d8f094ba4fbe.tar.bz2
gentoo-495db5935035929b44673c4b17e1d8f094ba4fbe.zip
dev-python/libnacl: version bump to 1.4.4
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-python/libnacl/libnacl-1.4.4.ebuild')
-rw-r--r--dev-python/libnacl/libnacl-1.4.4.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/libnacl/libnacl-1.4.4.ebuild b/dev-python/libnacl/libnacl-1.4.4.ebuild
new file mode 100644
index 000000000000..a9871fc31646
--- /dev/null
+++ b/dev-python/libnacl/libnacl-1.4.4.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=(python{2_7,3_3,3_4})
+inherit distutils-r1
+
+DESCRIPTION="Python ctypes wrapper for libsodium"
+HOMEPAGE="https://libnacl.readthedocs.org/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+RDEPEND="dev-libs/libsodium"
+
+python_test() {
+ ${EPYTHON} tests/runtests.py || die
+}