summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-22 05:24:01 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-22 05:40:20 +0200
commit65522d90d7e5f2dd0c347b1ed901a75673281fb5 (patch)
tree5668ca21c9fc5328a2e6a9ce23f8777ad8cd959f /dev-python/libtmux
parentdev-python/pyqtgraph: Bump to 0.13.6 (diff)
downloadgentoo-65522d90d7e5f2dd0c347b1ed901a75673281fb5.tar.gz
gentoo-65522d90d7e5f2dd0c347b1ed901a75673281fb5.tar.bz2
gentoo-65522d90d7e5f2dd0c347b1ed901a75673281fb5.zip
dev-python/libtmux: Bump to 0.37.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/libtmux')
-rw-r--r--dev-python/libtmux/Manifest1
-rw-r--r--dev-python/libtmux/libtmux-0.37.0.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/libtmux/Manifest b/dev-python/libtmux/Manifest
index 58dd02031fb4..5ae36e7af8b9 100644
--- a/dev-python/libtmux/Manifest
+++ b/dev-python/libtmux/Manifest
@@ -8,3 +8,4 @@ DIST libtmux-0.33.0.gh.tar.gz 282114 BLAKE2B d1b9b1e0789c81dab17a1d0be3708f34388
DIST libtmux-0.35.0.gh.tar.gz 282514 BLAKE2B b940e3833a54f949a73e19e1c8cdb97f91300425b4eff9f5b4ed0b60bfb117d0c670f3e450937bb453e0a7c2b7c623691d1ad8c42611bc486d65992680cbed9a SHA512 a847a5cd14f0daefaa7582610bcc5ab707aed16b73e4ff53f630bd27794dbdabf1c1d42635d30a3e3823413be79e9c2fcf3710096080b0eac3c49adecb816d59
DIST libtmux-0.35.1.gh.tar.gz 282665 BLAKE2B 7b28e4a4dbbea86102aa37bc1bca6d7de7d184b999dd4cbbe739770a32e0bcc5069f5822a79af426f41dc9ad25fda0cb3e23cba7a5b340b88259d552cb380356 SHA512 400eb10594032e9387a7408626d3be3281fdcb66ed06cc839732ccb39278c20f3f8d8f07e88ea03876a5afe38cb567e585c45716b1edb12cc8f6a89f20873a34
DIST libtmux-0.36.0.gh.tar.gz 282828 BLAKE2B 247f98ae47093090187f2d52792f850f7476427b368f46970ef3fe9bd6449c03ac23101c8c7af711167bbd92e9e2cff3754474375dabd48157154ed89975a71a SHA512 2fa16a55d4b46461d1266179cfa6cf8d710fdbe435369ff195a683a96243b2b7cd2fbeb47b88e3a660c23d3ca57e1c2722bc12492c52ee0961a1c5cc99ceb093
+DIST libtmux-0.37.0.gh.tar.gz 283496 BLAKE2B ef8c9c05cc20f549fc13ffb05276e1ba5b24c366c9cf44eb5ffe609cfe0e603ab7a90747b5df03afa62a6a9d8c81904e7fa7e4598092d3b11c0e9295e413d88d SHA512 8876ad13613d367d6a6ea5945b5a0a495460b5ad68a14d89d20a41f0e5b421e0007041e4e8356e88a8eefb2b2422be306aebd2452e3be556f1cc4fd232327499
diff --git a/dev-python/libtmux/libtmux-0.37.0.ebuild b/dev-python/libtmux/libtmux-0.37.0.ebuild
new file mode 100644
index 000000000000..60bbba2f66cb
--- /dev/null
+++ b/dev-python/libtmux/libtmux-0.37.0.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Typed library that provides an ORM wrapper for tmux, a terminal multiplexer"
+HOMEPAGE="
+ https://libtmux.git-pull.com/
+ https://github.com/tmux-python/libtmux/
+ https://pypi.org/project/libtmux/
+"
+SRC_URI="
+ https://github.com/tmux-python/libtmux/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+RDEPEND="
+ >=app-misc/tmux-3.0a
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-rerunfailures[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ local issues="https://github.com/tmux-python/libtmux/issues/"
+ sed -r -i "s|:issue:\`([[:digit:]]+)\`|\`issue \1 ${issues}\1\`|" CHANGES || die
+
+ # increase timeouts for tests
+ sed -e 's/0.01/0.1/' -i tests/test_test.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # tests/test_window.py::test_fresh_window_data fails if TMUX_PANE is set
+ # https://bugs.gentoo.org/927158
+ local -x TMUX_PANE=
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=libtmux.pytest_plugin
+
+ local EPYTEST_DESELECT=(
+ # flaky tests
+ tests/legacy_api/test_test.py::test_function_times_out
+ tests/legacy_api/test_test.py::test_function_times_out_no_raise
+ tests/legacy_api/test_test.py::test_function_times_out_no_raise_assert
+ )
+ epytest -o addopts= -p pytest_mock -p rerunfailures tests
+}