summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2016-10-04 21:55:27 -0500
committerMatthias Maier <tamiko@gentoo.org>2016-10-04 21:55:27 -0500
commit06349ff0c92167d5c440583808c9009d241096c8 (patch)
tree118bdb17cbfe1baff5cc48a278d0451e06fba6c6 /dev-python/libvirt-python
parentapp-emulation/libvirt: version bump to 2.3.0 (diff)
downloadgentoo-06349ff0c92167d5c440583808c9009d241096c8.tar.gz
gentoo-06349ff0c92167d5c440583808c9009d241096c8.tar.bz2
gentoo-06349ff0c92167d5c440583808c9009d241096c8.zip
dev-python/libvirt-python: version bump to 2.3.0
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python/libvirt-python')
-rw-r--r--dev-python/libvirt-python/Manifest1
-rw-r--r--dev-python/libvirt-python/libvirt-python-2.3.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/libvirt-python/Manifest b/dev-python/libvirt-python/Manifest
index e67765f9217b..2c9103b97ca9 100644
--- a/dev-python/libvirt-python/Manifest
+++ b/dev-python/libvirt-python/Manifest
@@ -2,3 +2,4 @@ DIST libvirt-python-1.3.5.tar.gz 168780 SHA256 a0508a57637fd18a3584fb9d2322fb172
DIST libvirt-python-2.0.0.tar.gz 170475 SHA256 7816cbc1c6ad140ba643b662825babb1ef586bd3ccfd0b04dfeba4ae2f2d1d40 SHA512 695de54ab79d10900c44d2e12be422692da03436f5f89bd4020f3e114d250a94e13c61d112287f2d0d3d1dfadd7309af501d4226a12925c4295e4b3aae20d88c WHIRLPOOL 48059b5a2c31194369096737d45ded7c64eed14055fb895e5844025c3f888a17473d32c717db5e4c5a84be8623c2f40d67efa87b7a261be68a13a06d9afb272d
DIST libvirt-python-2.1.0.tar.gz 170607 SHA256 74887fa1be60db2701e726da7e01e3bf18ecd3b8d1cfdf2f1f7480e1a1edbacb SHA512 8a031b7572c11f57a16292980188e4da830d1293aa1aab3fa35f9c18746e5628086643d8c6d6450d668d194dd3c792e0a5f61605f96dc11fa430c846e459529a WHIRLPOOL 96f02cc2870a9ecc722da1dbf2aa3f7d01fcbec6b5215329d75664e468d938a6ed7a5ff691618176539edaba0beb6ea0d01b02f328758099b343b86ac9e853e3
DIST libvirt-python-2.2.0.tar.gz 171557 SHA256 ba6b2eb3f018275e9720498d7b771959c2d51ebd54f6e956de5055f912afea76 SHA512 d3c6679e8e9a7c875c89078733a4a8b25c65d7a37c1bad8ded7bffc1b16cac0c0db93fd5c5bfc8433cd6dd657d5d307a9bb38cc1178ecc5c730f8e03d5d6ae1d WHIRLPOOL 6f5d9360bae2c7611fadecf546c0159ae718cc932c0aa096622d80b58972f4623c7efa7979be7397b7ff4dc3906d3df0bebb5ff62f4d5a239ff45840bae78edb
+DIST libvirt-python-2.3.0.tar.gz 171858 SHA256 ad25a98c2508a6c81d65cc8bc5f3e0b4c506247cf544a7d54c41526a99caef48 SHA512 87d3356c780f4f12a5dc7cf2b65d1d361b0572d476a207542118c276be1c46561d832c3ff7053affe06e0893f755af1f44d0a461c98980e9485363f827112b6b WHIRLPOOL 43d833296e5f750bf8e326dea76bfcee4947fe84eb5d0a1da6af160240da94354daf6b8b2f4d5eeb6dc5fcf7735c839e63a2e4844e07c56316e92279796fd0d0
diff --git a/dev-python/libvirt-python/libvirt-python-2.3.0.ebuild b/dev-python/libvirt-python/libvirt-python-2.3.0.ebuild
new file mode 100644
index 000000000000..4a025bf65e6b
--- /dev/null
+++ b/dev-python/libvirt-python/libvirt-python-2.3.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+AUTOTOOLIZE=yes
+
+MY_P="${P/_rc/-rc}"
+
+inherit eutils distutils-r1
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://libvirt.org/libvirt-python.git"
+ SRC_URI=""
+ KEYWORDS=""
+ RDEPEND="app-emulation/libvirt:=[-python(-)]"
+else
+ SRC_URI="http://libvirt.org/sources/python/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ RDEPEND="app-emulation/libvirt:0/${PV}"
+fi
+S="${WORKDIR}/${P%_rc*}"
+
+DESCRIPTION="libvirt Python bindings"
+HOMEPAGE="http://www.libvirt.org"
+LICENSE="LGPL-2"
+SLOT="0"
+IUSE="test"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}] )"
+
+# testsuite is currently not included in upstream tarball
+RESTRICT="test"
+
+python_test() {
+ esetup.py test
+}