summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2017-04-14 10:50:08 -0500
committerMatthias Maier <tamiko@gentoo.org>2017-04-14 10:55:42 -0500
commit325a15336237acf9f4f6340cc66ca4f71d340011 (patch)
tree6dd5b5d4dc851e542b4a9f79daa3a2eb7b73dd14 /dev-python/libvirt-python
parentapp-emulation/libvirt: bump to version 3.2.0, bug #615162 (diff)
downloadgentoo-325a15336237acf9f4f6340cc66ca4f71d340011.tar.gz
gentoo-325a15336237acf9f4f6340cc66ca4f71d340011.tar.bz2
gentoo-325a15336237acf9f4f6340cc66ca4f71d340011.zip
dev-python/libvirt-python: bump to version 3.2.0
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-python/libvirt-python')
-rw-r--r--dev-python/libvirt-python/Manifest1
-rw-r--r--dev-python/libvirt-python/libvirt-python-3.2.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/libvirt-python/Manifest b/dev-python/libvirt-python/Manifest
index a5e4e87c89ce..cde8ec2adf3d 100644
--- a/dev-python/libvirt-python/Manifest
+++ b/dev-python/libvirt-python/Manifest
@@ -3,3 +3,4 @@ DIST libvirt-python-2.1.0.tar.gz 170607 SHA256 74887fa1be60db2701e726da7e01e3bf1
DIST libvirt-python-2.3.0.tar.gz 171858 SHA256 ad25a98c2508a6c81d65cc8bc5f3e0b4c506247cf544a7d54c41526a99caef48 SHA512 87d3356c780f4f12a5dc7cf2b65d1d361b0572d476a207542118c276be1c46561d832c3ff7053affe06e0893f755af1f44d0a461c98980e9485363f827112b6b WHIRLPOOL 43d833296e5f750bf8e326dea76bfcee4947fe84eb5d0a1da6af160240da94354daf6b8b2f4d5eeb6dc5fcf7735c839e63a2e4844e07c56316e92279796fd0d0
DIST libvirt-python-2.5.0.tar.gz 172329 SHA256 f4fd787ad26b4cd4b32afa65b6248c344ef48edffeb42c892c7adb4866f656d1 SHA512 2ff94ff12c20d9d0e5be8b571bc33fb1641e9940c6b49cdee37244c941674b12e1c980f9e0c73f4db52c91579ab19f92cea0c2e79a97abc67ee3309028661bb6 WHIRLPOOL 78712a122edfd4ce32e73332c8311e6b661be843f10ab30d3d85d426a266ddddbe36d30bfc09e63016189b8ffffe729119884d0d4acb05844b2bef37f8fadd63
DIST libvirt-python-3.1.0.tar.gz 174378 SHA256 f36a62ace3b815ef1f14a760a5feee31bd502bed0daf92ab75d21d516123a218 SHA512 33b8cff940a66c658b104ef2129d88eff11f2c70fc5f92d448e4963a205c978d3dd218068339dcaa20fabdd666a30e887262d17dd1f5b98cc8566ba2d8276400 WHIRLPOOL a4f3f6268d1ec2aef0f3d9d522183067524e0a7f319e57703cdb640b8b3258730731e8eecb923c8fe270fed77db8c3127776953a7587095c4040cdbd75a08523
+DIST libvirt-python-3.2.0.tar.gz 174713 SHA256 ac85dd8dec332f308e5e0e40889be0d2f10b5d6917f00f0c474405ad25dc003d SHA512 d13cb0fb46844cab512931fbb85225bdd99c44eba0761caaeb13a40f8bf18700d5836f4e24300370810ee103b4f391699db13ae0523e5625a566a9c5b41d12d5 WHIRLPOOL 9c7d1dd4a92da276f5368b80d31c11032ae0ce2ea337e21f830d433d5e7ec90759484720264a3c494f4881c8b10ce11dfbf20da0c5b89f75c0bff61cc508a065
diff --git a/dev-python/libvirt-python/libvirt-python-3.2.0.ebuild b/dev-python/libvirt-python/libvirt-python-3.2.0.ebuild
new file mode 100644
index 000000000000..f93eb35e154c
--- /dev/null
+++ b/dev-python/libvirt-python/libvirt-python-3.2.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+MY_P="${P/_rc/-rc}"
+
+inherit distutils-r1
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://libvirt.org/libvirt-python.git"
+ SRC_URI=""
+ KEYWORDS=""
+ RDEPEND="app-emulation/libvirt:=[-python(-)]"
+else
+ SRC_URI="http://libvirt.org/sources/python/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ RDEPEND="app-emulation/libvirt:0/${PV}"
+fi
+S="${WORKDIR}/${P%_rc*}"
+
+DESCRIPTION="libvirt Python bindings"
+HOMEPAGE="https://www.libvirt.org"
+LICENSE="LGPL-2"
+SLOT="0"
+IUSE="examples test"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}