summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2015-12-26 23:59:06 +0100
committerMatthias Maier <tamiko@gentoo.org>2015-12-27 00:02:07 +0100
commit4d582919852ebc5cb1ee5cedc1a02cdb8d199158 (patch)
tree3c1cc4719e3c7a2f1ad07b8c5882ae5dba746528 /dev-python/libvirt-python
parentapp-emulation/libvirt: version bump to 1.3.0, provde service file for virtlogd (diff)
downloadgentoo-4d582919852ebc5cb1ee5cedc1a02cdb8d199158.tar.gz
gentoo-4d582919852ebc5cb1ee5cedc1a02cdb8d199158.tar.bz2
gentoo-4d582919852ebc5cb1ee5cedc1a02cdb8d199158.zip
dev-python/libvirt-python: version bump to 1.3.0
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-python/libvirt-python')
-rw-r--r--dev-python/libvirt-python/Manifest1
-rw-r--r--dev-python/libvirt-python/libvirt-python-1.3.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/libvirt-python/Manifest b/dev-python/libvirt-python/Manifest
index d76ebb0ebcd4..338a2aceb0aa 100644
--- a/dev-python/libvirt-python/Manifest
+++ b/dev-python/libvirt-python/Manifest
@@ -1 +1,2 @@
DIST libvirt-python-1.2.21.tar.gz 171250 SHA256 7ffb49fcb64ac06188fc626c853c99361e5965766ab020f8ea66f8fbcfc29684 SHA512 7e2481ffa26105ddde703bd6eafe74240b69990b2f2ce0042f20f7fceb1d326fb8a66bf26042bfe63a12cf3202d7c19b14b6d766dd42fb66af212393d7aaf332 WHIRLPOOL 18dd5bc0d565b6846c40960cf258d7fb3714054be15fe54507e2846c5a7c2cd81e9b209c8e70cbfd5319d5a06f00c2c5322995058637af87d1676276f8675b2e
+DIST libvirt-python-1.3.0.tar.gz 171195 SHA256 097d41bc52c300e50c5b04836e078bae5653fe222db92a9a10839f3e6b3afc7c SHA512 b207aa9aef63e7d1a8377b2f8a0fa8dc05893bd744672c2b41f4dafa2516cbddd2868f37b0caf72b125fccbbf56542fcf1b94b452c406757f30d8f02d6ee26b4 WHIRLPOOL 1bde1fd130e0760bfa8f62c2f85e4ded991fc0eadcaf10b38bbbcf754eaa7b3a0ccb72f304f65457115419e4d3d904d07172e33bd68d581a29e4fb8d0703b45a
diff --git a/dev-python/libvirt-python/libvirt-python-1.3.0.ebuild b/dev-python/libvirt-python/libvirt-python-1.3.0.ebuild
new file mode 100644
index 000000000000..cc59d1ba63b0
--- /dev/null
+++ b/dev-python/libvirt-python/libvirt-python-1.3.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} )
+
+AUTOTOOLIZE=yes
+
+MY_P="${P/_rc/-rc}"
+
+inherit eutils distutils-r1
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="git://libvirt.org/libvirt-python.git"
+ SRC_URI=""
+ KEYWORDS=""
+ RDEPEND="app-emulation/libvirt:=[-python(-)]"
+else
+ SRC_URI="http://libvirt.org/sources/python/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ RDEPEND="app-emulation/libvirt:0/${PV}"
+fi
+S="${WORKDIR}/${P%_rc*}"
+
+DESCRIPTION="libvirt Python bindings"
+HOMEPAGE="http://www.libvirt.org"
+LICENSE="LGPL-2"
+SLOT="0"
+IUSE="test"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}] )"
+
+# testsuite is currently not included in upstream tarball
+RESTRICT="test"
+
+python_test() {
+ esetup.py test
+}