summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2022-06-03 04:08:05 +0100
committerSam James <sam@gentoo.org>2022-06-03 04:08:46 +0100
commit69f50293a96d7cb08db0b2a37001476838c08a96 (patch)
treec47460626391fb49f045908bd47ebad71465ee38 /dev-python/libvirt-python
parentapp-emacs/nxml-libvirt-schemas: add 8.4.0 (diff)
downloadgentoo-69f50293a96d7cb08db0b2a37001476838c08a96.tar.gz
gentoo-69f50293a96d7cb08db0b2a37001476838c08a96.tar.bz2
gentoo-69f50293a96d7cb08db0b2a37001476838c08a96.zip
dev-python/libvirt-python: add 8.4.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/libvirt-python')
-rw-r--r--dev-python/libvirt-python/Manifest2
-rw-r--r--dev-python/libvirt-python/libvirt-python-8.4.0.ebuild56
-rw-r--r--dev-python/libvirt-python/libvirt-python-9999.ebuild2
3 files changed, 59 insertions, 1 deletions
diff --git a/dev-python/libvirt-python/Manifest b/dev-python/libvirt-python/Manifest
index 5d8b34c01876..bc4ae5f19b75 100644
--- a/dev-python/libvirt-python/Manifest
+++ b/dev-python/libvirt-python/Manifest
@@ -10,3 +10,5 @@ DIST libvirt-python-8.2.0.tar.gz 223589 BLAKE2B 6c8d39e6af1167aa24a1c0710177188a
DIST libvirt-python-8.2.0.tar.gz.asc 833 BLAKE2B 262a8072b58b19f871a72ed81d8dcab907130ce6f25f6478c72e6f3e7d8d51226fda1844a37baf82667d2f35ef3e64e84e47de1d33217a356ea1d78fec6aa548 SHA512 11ea846816a3300940b9792a5a778c633bb2d9e0523f442588ae82f8fb46ecc0256267b2efece655331112e3912c9bfcf46247555e48d1861999d1363f6034b1
DIST libvirt-python-8.3.0.tar.gz 231579 BLAKE2B 0bd169b66f490e100eab95f94f412d27836a302d57c4771a35154995122fa23a4b9f8c836b622bbb1d7790664ab5c8c25f7158b2c11dcbfcf48ebf6bb6dc32db SHA512 8b50e4142f14e60bc50065bb3708bb04deb3f72061b056492cca52b866bf86f0b7b47e2f8de39d4f8898cf860f7247d0cb243eb2ad6a9329b27fc890f727ebd8
DIST libvirt-python-8.3.0.tar.gz.asc 833 BLAKE2B bb19bef914e39d04b6580dcce1813bc21c5213a2b4c88d44686eeecc9ffc9383db3bab62d46840138a9a9e80d6429662aec43d586dddc041bca4543ff49c465b SHA512 65d417a6849614f94a59dca94cb258b7de487fbc409cd2cfc8c3e9cbdc76ae83c6c2c40a0cf4c12877d2fa78bbcf371512ca6f71973466d2151be690a8b4422c
+DIST libvirt-python-8.4.0.tar.gz 231985 BLAKE2B 64d37074e04cdb02332987dc46e6dd7b38dbc8fa4de0e6e1cbde1caba370f5eed650c4a135f6101c355f189a91fbba82dcac3d50f8c0d0678ce4def448a4b168 SHA512 6c831ae45549ab0c4d720826e2f5cb219eaab0943b8c71fe70c02fd49097fb5565ee6f651b19e34f72d6b0133bf3b4bb8bfe56b37723b24eaf336f65ab0a5865
+DIST libvirt-python-8.4.0.tar.gz.asc 833 BLAKE2B fa6f5e10ca3e06c017e9988e676dd2beca2bcb88f4d55d7a1740d42b4ea56ff0cdb4fd7698392ce1eead7a81fafcc1475eb6270329f56e191a4a4551120e982b SHA512 855869856ff41338c4ed1b707db4a0ace97a60e51d19183a0c1f904695b8a367249ae6266a45d79449443325cc85485db89dc73b09ac318c206cc03ab36ef179
diff --git a/dev-python/libvirt-python/libvirt-python-8.4.0.ebuild b/dev-python/libvirt-python/libvirt-python-8.4.0.ebuild
new file mode 100644
index 000000000000..59818c6c51d9
--- /dev/null
+++ b/dev-python/libvirt-python/libvirt-python-8.4.0.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+# Packages which get releases together:
+# app-emacs/nxml-libvirt-schemas
+# dev-python/libvirt-python
+# dev-perl/Sys-Virt
+# app-emulation/libvirt
+# Please bump them together!
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+MY_P="${P/_rc/-rc}"
+VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/libvirt.org.asc
+inherit distutils-r1 verify-sig
+
+if [[ ${PV} == *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://gitlab.com/libvirt/libvirt-python.git"
+ RDEPEND="app-emulation/libvirt:=[-python(-)]"
+else
+ SRC_URI="https://libvirt.org/sources/python/${MY_P}.tar.gz
+ verify-sig? ( https://libvirt.org/sources/python/${MY_P}.tar.gz.asc )"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+ RDEPEND="app-emulation/libvirt:0/${PV}"
+fi
+S="${WORKDIR}/${P%_rc*}"
+
+DESCRIPTION="libvirt Python bindings"
+HOMEPAGE="https://www.libvirt.org"
+
+LICENSE="LGPL-2"
+SLOT="0"
+IUSE="examples test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="
+ virtual/pkgconfig
+ test? (
+ dev-python/lxml[${PYTHON_USEDEP}]
+ )
+ verify-sig? ( sec-keys/openpgp-keys-libvirt )
+"
+
+distutils_enable_tests pytest
+
+python_install_all() {
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/libvirt-python/libvirt-python-9999.ebuild b/dev-python/libvirt-python/libvirt-python-9999.ebuild
index cd3ceb1cc71e..59818c6c51d9 100644
--- a/dev-python/libvirt-python/libvirt-python-9999.ebuild
+++ b/dev-python/libvirt-python/libvirt-python-9999.ebuild
@@ -1,7 +1,7 @@
# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
# Packages which get releases together:
# app-emacs/nxml-libvirt-schemas