summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2018-11-04 00:02:45 -0500
committerMatthias Maier <tamiko@gentoo.org>2018-11-04 00:13:31 -0500
commita4cb8787d37afd433f2c14d5c46278a3f7ecfb16 (patch)
treeef11abf77aa6c673fe1b0a3fb9ca5792245a00f9 /dev-python/libvirt-python
parentapp-emulation/libvirt: update live ebuild (diff)
downloadgentoo-a4cb8787d37afd433f2c14d5c46278a3f7ecfb16.tar.gz
gentoo-a4cb8787d37afd433f2c14d5c46278a3f7ecfb16.tar.bz2
gentoo-a4cb8787d37afd433f2c14d5c46278a3f7ecfb16.zip
dev-python/libvirt-python: version bump to 4.8.0
Signed-off-by: Matthias Maier <tamiko@gentoo.org> Package-Manager: Portage-2.3.51, Repoman-2.3.11
Diffstat (limited to 'dev-python/libvirt-python')
-rw-r--r--dev-python/libvirt-python/Manifest1
-rw-r--r--dev-python/libvirt-python/libvirt-python-4.8.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/libvirt-python/Manifest b/dev-python/libvirt-python/Manifest
index 89cf71c17e56..c1f627e2fd29 100644
--- a/dev-python/libvirt-python/Manifest
+++ b/dev-python/libvirt-python/Manifest
@@ -2,3 +2,4 @@ DIST libvirt-python-4.3.0.tar.gz 187111 BLAKE2B 7266ca1b5836429e13a03dab0e2f5085
DIST libvirt-python-4.4.0.tar.gz 188431 BLAKE2B dc2dfc64139c3bb2a80516c345b1256311b1b2ceaa832de2ef60afe5422adabee626b25dffa96a1bd8428f4d0bd54ed5264d887522700a941aa646b4b43a7f8c SHA512 b4e740895c22aca20d8fc1cfadc9276e91e0a74aa7bad75d15de14be6704be8386055b700ea65045acfaabf3bfe8fa51e5d814e625e46d01b3ac0221419d25da
DIST libvirt-python-4.5.0.tar.gz 190016 BLAKE2B ba3aa68b2de6179cfddaff54bf96fa876959d97e72245ccdad8f9f681641166f5827d5244ae4c18b7a7b90a3201b3a797d30c2436a6ab5fcdbcfd56462348ba4 SHA512 14572225c2f5233aa8cb7257cff94d38effc4d988aac36108ca510dcd442d8c5194d6b25bddb2603bb1e1bc4dcb284f103899ce81063dc6a7994d78beea355ac
DIST libvirt-python-4.6.0.tar.gz 190306 BLAKE2B ed3659e69408e7b8b5f0ea3404a2e72c6e9c1fbc5c13352c535a3c30980e7d50f5cd1a2c4aea4438665ea3e9e506a91787b5ce43d5199f7c5d4bd25f22186033 SHA512 15c71820ea3c3f71cfa127b82374f05cc99d4ed5189ad9ec0e471b3491fc4050f7f938590a46f0eb9d9efcbf45971881ed4f40376619a9f6b3796459626d645c
+DIST libvirt-python-4.8.0.tar.gz 191575 BLAKE2B eda117ae3644a944bad3b98e2625cf77f69723109c1ac6f083894f56eaff0808a22ef1f62a73fa9b97b0e12fb95badb2a22e41e9a6e01c03f38bf23ecc4615c1 SHA512 f54740a185e8464e897bbd3a6709577e4b0cd9df6f75789b15d6d35067187846bc925f30c94b124131f742552276f9574bcb549c9e7577db952c17c0546f8fb5
diff --git a/dev-python/libvirt-python/libvirt-python-4.8.0.ebuild b/dev-python/libvirt-python/libvirt-python-4.8.0.ebuild
new file mode 100644
index 000000000000..968deb8ce73c
--- /dev/null
+++ b/dev-python/libvirt-python/libvirt-python-4.8.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+MY_P="${P/_rc/-rc}"
+
+inherit distutils-r1
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://libvirt.org/git/libvirt-python.git"
+ SRC_URI=""
+ KEYWORDS=""
+ RDEPEND="app-emulation/libvirt:=[-python(-)]"
+else
+ SRC_URI="https://libvirt.org/sources/python/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+ RDEPEND="app-emulation/libvirt:0/${PV}"
+fi
+S="${WORKDIR}/${P%_rc*}"
+
+DESCRIPTION="libvirt Python bindings"
+HOMEPAGE="https://www.libvirt.org"
+LICENSE="LGPL-2"
+SLOT="0"
+IUSE="examples test"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}