summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2019-03-17 02:12:56 -0500
committerMatthias Maier <tamiko@gentoo.org>2019-03-17 02:27:27 -0500
commitab799731e71c3ddaf7dfce570044d4c005c5a54e (patch)
tree350670fb77e6e23e725ce02044e52031435557de /dev-python/libvirt-python
parentdev-python/libvirt-python: drop old (diff)
downloadgentoo-ab799731e71c3ddaf7dfce570044d4c005c5a54e.tar.gz
gentoo-ab799731e71c3ddaf7dfce570044d4c005c5a54e.tar.bz2
gentoo-ab799731e71c3ddaf7dfce570044d4c005c5a54e.zip
dev-python/libvirt-python: version bump to 5.1.0
Package-Manager: Portage-2.3.62, Repoman-2.3.12 Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'dev-python/libvirt-python')
-rw-r--r--dev-python/libvirt-python/Manifest1
-rw-r--r--dev-python/libvirt-python/libvirt-python-5.1.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/libvirt-python/Manifest b/dev-python/libvirt-python/Manifest
index 0e2883e049eb..7dd7b02accd0 100644
--- a/dev-python/libvirt-python/Manifest
+++ b/dev-python/libvirt-python/Manifest
@@ -1,2 +1,3 @@
DIST libvirt-python-4.9.0.tar.gz 191922 BLAKE2B 272f0827faa7083e4896b34cea81554505e38733313df556d608fbf0e2ab935088ec5d57e9678c7679e172ff99a619939abe8cbd828b49655de70daf11d20efe SHA512 7d1345693c87f11be9dc751212820f4c4a519a467703f0ea2fcafd0e66d39941686cf7c84c2c68e8639889da1bfbc9176a72cf1059c87d76a49b2c74a7b05c0e
DIST libvirt-python-5.0.0.tar.gz 192726 BLAKE2B 1ab4d4430254a1288714db32d76baf4a78f733bd82d33cf9f6a40aadcfac9c1dd73db91d38326a68ad04b8454f4c6417a16f07f9ecdfe8ccabcb0eccc9d13060 SHA512 318ae32f4c59b6cd278c8d07566e5e5f34759167084d4c722687d3cbf19efecea3a0c2a4ee37f42e58aa3f42f07fdd50bd9dd0539002388a7f79b138ad434dff
+DIST libvirt-python-5.1.0.tar.gz 193081 BLAKE2B 7dc0914743257f53a285ae794c64e360af72085db532deb552925d68f5be07f20d3b2ff242b8d475e40ea6ede06bd9abe790f3bcbf4ab8b7aba2a9c6120aa236 SHA512 980bcb1723ea5bf0677a1c7de9fc8f23cd4495df3c861e2c0c865c53c30eb7cb1db4c6c369c593206378f2e80211bf4542304f73e8953bfe513b80b7ed013e74
diff --git a/dev-python/libvirt-python/libvirt-python-5.1.0.ebuild b/dev-python/libvirt-python/libvirt-python-5.1.0.ebuild
new file mode 100644
index 000000000000..92f5219f4a06
--- /dev/null
+++ b/dev-python/libvirt-python/libvirt-python-5.1.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6,3_7} )
+
+MY_P="${P/_rc/-rc}"
+
+inherit distutils-r1
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://libvirt.org/git/libvirt-python.git"
+ SRC_URI=""
+ KEYWORDS=""
+ RDEPEND="app-emulation/libvirt:=[-python(-)]"
+else
+ SRC_URI="https://libvirt.org/sources/python/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+ RDEPEND="app-emulation/libvirt:0/${PV}"
+fi
+S="${WORKDIR}/${P%_rc*}"
+
+DESCRIPTION="libvirt Python bindings"
+HOMEPAGE="https://www.libvirt.org"
+LICENSE="LGPL-2"
+SLOT="0"
+IUSE="examples test"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}