summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2019-07-01 09:34:54 -0500
committerMatthias Maier <tamiko@gentoo.org>2019-07-01 09:34:54 -0500
commitb18edfebbb51d0279052e383352c0dfae8c821b7 (patch)
tree87145202f34bd0c054cab35e0b9eea3a2c3ce2cb /dev-python/libvirt-python
parentapp-emulation/libvirt: fix apparmor (diff)
downloadgentoo-b18edfebbb51d0279052e383352c0dfae8c821b7.tar.gz
gentoo-b18edfebbb51d0279052e383352c0dfae8c821b7.tar.bz2
gentoo-b18edfebbb51d0279052e383352c0dfae8c821b7.zip
dev-python/libvirt-python: drop old
Package-Manager: Portage-2.3.68, Repoman-2.3.16 Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'dev-python/libvirt-python')
-rw-r--r--dev-python/libvirt-python/Manifest1
-rw-r--r--dev-python/libvirt-python/libvirt-python-4.9.0.ebuild46
2 files changed, 0 insertions, 47 deletions
diff --git a/dev-python/libvirt-python/Manifest b/dev-python/libvirt-python/Manifest
index 3a59b8819b44..061a8a1114e6 100644
--- a/dev-python/libvirt-python/Manifest
+++ b/dev-python/libvirt-python/Manifest
@@ -1,2 +1 @@
-DIST libvirt-python-4.9.0.tar.gz 191922 BLAKE2B 272f0827faa7083e4896b34cea81554505e38733313df556d608fbf0e2ab935088ec5d57e9678c7679e172ff99a619939abe8cbd828b49655de70daf11d20efe SHA512 7d1345693c87f11be9dc751212820f4c4a519a467703f0ea2fcafd0e66d39941686cf7c84c2c68e8639889da1bfbc9176a72cf1059c87d76a49b2c74a7b05c0e
DIST libvirt-python-5.2.0.tar.gz 193270 BLAKE2B fecd1a07091746779a91e0cfeb9c3068048ee7e51d2f79064b4ee529a19b78d04ba53a5abab68182a1fa9c4a82f459fa9e971c33fcd10b42fe7011be17f7c6e2 SHA512 afee2dcaf08d530e6298fdf2db674af217b9e4115941258b5815aba00087d96db6eb421c9854d7dca0f9dfe24069df72aadd969c924545e72be216f01bc173cc
diff --git a/dev-python/libvirt-python/libvirt-python-4.9.0.ebuild b/dev-python/libvirt-python/libvirt-python-4.9.0.ebuild
deleted file mode 100644
index 7508f20cc56e..000000000000
--- a/dev-python/libvirt-python/libvirt-python-4.9.0.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} )
-
-MY_P="${P/_rc/-rc}"
-
-inherit distutils-r1
-
-if [[ ${PV} = *9999* ]]; then
- inherit git-r3
- EGIT_REPO_URI="https://libvirt.org/git/libvirt-python.git"
- SRC_URI=""
- KEYWORDS="amd64 x86"
- RDEPEND="app-emulation/libvirt:=[-python(-)]"
-else
- SRC_URI="https://libvirt.org/sources/python/${MY_P}.tar.gz"
- KEYWORDS="amd64 ~arm64 x86"
- RDEPEND="app-emulation/libvirt:0/${PV}"
-fi
-S="${WORKDIR}/${P%_rc*}"
-
-DESCRIPTION="libvirt Python bindings"
-HOMEPAGE="https://www.libvirt.org"
-LICENSE="LGPL-2"
-SLOT="0"
-IUSE="examples test"
-
-DEPEND="${RDEPEND}
- virtual/pkgconfig
- test? ( dev-python/lxml[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}] )"
-
-python_test() {
- esetup.py test
-}
-
-python_install_all() {
- if use examples; then
- dodoc -r examples
- docompress -x /usr/share/doc/${PF}/examples
- fi
- distutils-r1_python_install_all
-}