summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2018-12-25 21:05:24 -0600
committerMatthias Maier <tamiko@gentoo.org>2018-12-25 21:27:12 -0600
commiteb8b77af4bcc9f028a1ec3b6622d3d678e140a6a (patch)
tree61ffa09af593e3b180055553e1a53fc0bdefebe5 /dev-python/libvirt-python
parentapp-emulation/libvirt: version bump to 4.10.0 (diff)
downloadgentoo-eb8b77af4bcc9f028a1ec3b6622d3d678e140a6a.tar.gz
gentoo-eb8b77af4bcc9f028a1ec3b6622d3d678e140a6a.tar.bz2
gentoo-eb8b77af4bcc9f028a1ec3b6622d3d678e140a6a.zip
dev-python/libvirt-python: version bump to 4.10.0
Package-Manager: Portage-2.3.52, Repoman-2.3.12 Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'dev-python/libvirt-python')
-rw-r--r--dev-python/libvirt-python/Manifest1
-rw-r--r--dev-python/libvirt-python/libvirt-python-4.10.0.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/libvirt-python/Manifest b/dev-python/libvirt-python/Manifest
index bcb2810ddb0c..a0799355aed6 100644
--- a/dev-python/libvirt-python/Manifest
+++ b/dev-python/libvirt-python/Manifest
@@ -1,2 +1,3 @@
+DIST libvirt-python-4.10.0.tar.gz 192707 BLAKE2B b128bdb4e33ce3ee826f30ef06cae080df4da01fdba04a65747ce6f6dbf6b1b4383b2dc010c3cdae9a33c2d9a816f4f5214d8f095aa719056af94f723860a70e SHA512 30fac35ae04c18b340b5173c2a1ccb867147da3673a4b72ad612fb5f03b95ee9259459ef9e11cba4a101e7aef4b71d13e1b79a25eab39899a22c0e8261aba7ac
DIST libvirt-python-4.5.0.tar.gz 190016 BLAKE2B ba3aa68b2de6179cfddaff54bf96fa876959d97e72245ccdad8f9f681641166f5827d5244ae4c18b7a7b90a3201b3a797d30c2436a6ab5fcdbcfd56462348ba4 SHA512 14572225c2f5233aa8cb7257cff94d38effc4d988aac36108ca510dcd442d8c5194d6b25bddb2603bb1e1bc4dcb284f103899ce81063dc6a7994d78beea355ac
DIST libvirt-python-4.9.0.tar.gz 191922 BLAKE2B 272f0827faa7083e4896b34cea81554505e38733313df556d608fbf0e2ab935088ec5d57e9678c7679e172ff99a619939abe8cbd828b49655de70daf11d20efe SHA512 7d1345693c87f11be9dc751212820f4c4a519a467703f0ea2fcafd0e66d39941686cf7c84c2c68e8639889da1bfbc9176a72cf1059c87d76a49b2c74a7b05c0e
diff --git a/dev-python/libvirt-python/libvirt-python-4.10.0.ebuild b/dev-python/libvirt-python/libvirt-python-4.10.0.ebuild
new file mode 100644
index 000000000000..514949ce2b06
--- /dev/null
+++ b/dev-python/libvirt-python/libvirt-python-4.10.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6,3_7} )
+
+MY_P="${P/_rc/-rc}"
+
+inherit distutils-r1
+
+if [[ ${PV} = *9999* ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://libvirt.org/git/libvirt-python.git"
+ SRC_URI=""
+ KEYWORDS=""
+ RDEPEND="app-emulation/libvirt:=[-python(-)]"
+else
+ SRC_URI="https://libvirt.org/sources/python/${MY_P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86"
+ RDEPEND="app-emulation/libvirt:0/${PV}"
+fi
+S="${WORKDIR}/${P%_rc*}"
+
+DESCRIPTION="libvirt Python bindings"
+HOMEPAGE="https://www.libvirt.org"
+LICENSE="LGPL-2"
+SLOT="0"
+IUSE="examples test"
+
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? ( dev-python/lxml[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_test() {
+ esetup.py test
+}
+
+python_install_all() {
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+ distutils-r1_python_install_all
+}