summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2017-02-06 08:22:39 +0100
committerDavid Seifert <soap@gentoo.org>2017-02-06 09:08:13 +0100
commitc5749ef3cce4c04c359df5bfaf0dddec71b21b00 (patch)
tree169a36dc7a9e19804eda8684a2d3f51ce422d733 /dev-python/line_profiler
parentdev-scheme/guile-json: fix dep bug #608296 (diff)
downloadgentoo-c5749ef3cce4c04c359df5bfaf0dddec71b21b00.tar.gz
gentoo-c5749ef3cce4c04c359df5bfaf0dddec71b21b00.tar.bz2
gentoo-c5749ef3cce4c04c359df5bfaf0dddec71b21b00.zip
dev-python/line_profiler: Version bump to 2.0
Package-Manager: portage-2.3.3 Closes: https://github.com/gentoo/gentoo/pull/3784
Diffstat (limited to 'dev-python/line_profiler')
-rw-r--r--dev-python/line_profiler/Manifest1
-rw-r--r--dev-python/line_profiler/line_profiler-2.0.ebuild29
2 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/line_profiler/Manifest b/dev-python/line_profiler/Manifest
index abe554928bcf..a24fecd1c241 100644
--- a/dev-python/line_profiler/Manifest
+++ b/dev-python/line_profiler/Manifest
@@ -1 +1,2 @@
DIST line_profiler-1.0.tar.gz 65862 SHA256 a9e0c9ffa814f1215107c86c890afa8e63bec5a37d951f6f9d3668c1df2b1900 SHA512 15dd7ee10951287a5030eaff28e729e82094ec41d8e8dec803d5e44c6b9036ecbf1198365ef43c1fdd28451dec260c6491d118f1762d99fe037bb85eb7908dda WHIRLPOOL 1fd56ea4777a3c569807a124c708018fc77e68521d1f1ecdb13c343ddad3fcd881353cd71a0af36d06a12f1dd17be0f2731040fca5e827a4936298057dabf917
+DIST line_profiler-2.0.tar.gz 68478 SHA256 739f8ad0e4bcd0cb82e99afc09e00a0351234f6b3f0b1f7f0090a8a2fbbf8381 SHA512 c0335fc69fb47c150fa5555af4f7fdf4b172ca12ee6512e04ba854c4a81f3e6ee5594e484d11c8ea7e9e8048e3f3b8661db52332d4ac645195a0e050acea4ecb WHIRLPOOL 6f4a3816fb22c86fe1c691a3e949be41da7680055db5c0909dbfb9af4052cfa50640eca43e0e918e903c23c9e6b8858ebff76e4fa21d8648084ade74f45a2915
diff --git a/dev-python/line_profiler/line_profiler-2.0.ebuild b/dev-python/line_profiler/line_profiler-2.0.ebuild
new file mode 100644
index 000000000000..638f08c97974
--- /dev/null
+++ b/dev-python/line_profiler/line_profiler-2.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Line-by-line profiler"
+HOMEPAGE="https://github.com/rkern/line_profiler"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="dev-python/ipython[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+ "
+
+python_test() {
+ "${EPYTHON}" -m unittest discover -v "${S}"/tests/ \
+ || die "Tests failed with ${EPYTHON}"
+}