summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-30 13:16:36 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-30 20:13:50 +0200
commitb1ed8077bef4f138ef33b9801044262bf387cef9 (patch)
treefa8bd3461c7e463ef129ac1f93a90d0c73257741 /dev-python/lit
parentdev-python/clang-python: Bump live to 14* (diff)
downloadgentoo-b1ed8077bef4f138ef33b9801044262bf387cef9.tar.gz
gentoo-b1ed8077bef4f138ef33b9801044262bf387cef9.tar.bz2
gentoo-b1ed8077bef4f138ef33b9801044262bf387cef9.zip
dev-python/lit: Bump live to 14*
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/lit')
-rw-r--r--dev-python/lit/lit-14.0.0.9999.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/lit/lit-14.0.0.9999.ebuild b/dev-python/lit/lit-14.0.0.9999.ebuild
new file mode 100644
index 000000000000..37168fbde9bd
--- /dev/null
+++ b/dev-python/lit/lit-14.0.0.9999.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 llvm.org
+
+DESCRIPTION="A stand-alone install of the LLVM suite testing tool"
+HOMEPAGE="https://llvm.org/"
+
+LICENSE="Apache-2.0-with-LLVM-exceptions UoI-NCSA"
+SLOT="0"
+KEYWORDS=""
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+# Tests require 'FileCheck' and 'not' utilities (from llvm)
+BDEPEND="
+ test? (
+ dev-python/psutil[${PYTHON_USEDEP}]
+ sys-devel/llvm )"
+
+LLVM_COMPONENTS=( llvm/utils/lit )
+llvm.org_set_globals
+
+# TODO: move the manpage generation here (from sys-devel/llvm)
+
+src_prepare() {
+ cd "${WORKDIR}" || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local -x LIT_PRESERVES_TMP=1
+ local litflags=$(get_lit_flags)
+ ./lit.py ${litflags//;/ } tests || die
+}