summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-03-12 12:34:43 -0500
committerTim Harder <radhermit@gentoo.org>2016-03-12 13:14:35 -0500
commit216ab37fc7eb97b6e41dcebafea7076b5381fc98 (patch)
treebdb8385d16b84c4168cd25424c3cf639209e2279 /dev-python/llfuse
parentdev-python/trollius: version bump to 2.1 (diff)
downloadgentoo-216ab37fc7eb97b6e41dcebafea7076b5381fc98.tar.gz
gentoo-216ab37fc7eb97b6e41dcebafea7076b5381fc98.tar.bz2
gentoo-216ab37fc7eb97b6e41dcebafea7076b5381fc98.zip
dev-python/llfuse: version bump to 1.0
Diffstat (limited to 'dev-python/llfuse')
-rw-r--r--dev-python/llfuse/Manifest1
-rw-r--r--dev-python/llfuse/llfuse-1.0.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/llfuse/Manifest b/dev-python/llfuse/Manifest
index 540cf3e21252..257d4c64ef80 100644
--- a/dev-python/llfuse/Manifest
+++ b/dev-python/llfuse/Manifest
@@ -2,3 +2,4 @@ DIST llfuse-0.40.tar.bz2 454032 SHA256 ee8b1125a6f2ab904d617d7602d86c0e3f69e4031
DIST llfuse-0.41.tar.bz2 397155 SHA256 58079acce2ed03305bfea998cfad7c5d1815c85c263e0a21f692d4cdb7d01bde SHA512 5c8bd2cf4bb5dec624fa3aa96aeadd2583cdfa45a9331d62e395ca2007c96f8ae667dba40568e1a17f30157b1d0ca123fe68639d78d117cd83c2405649bf166d WHIRLPOOL da876ab8502682cf77e711e9d2d8be5e74e6aa0d8bc639e7b55afa2f76d15173e5651706310b3814ef3a820c6afe45a50134cfa61e5db93fab452c222ef9394b
DIST llfuse-0.42.1.tar.bz2 320282 SHA256 8ee9f190682d1c94e6522e77064fcdb4c7b07e71a6b9d1193ac1527972a98b59 SHA512 b87b26a3b19db954110248233f393c2c445d42b0fd89d83da3282d1f21f9ef6285721f3348e86d00d46584e3fc9896c6111d9573a103505476ab4f59d2c1b444 WHIRLPOOL c08d356e8170180aba87de9b5fb8f716a99865040582f90ec4a144c88b27f10f5e36ef4af20a29367cf3e4ae971a1a1b731e2717f7d1dece70754af49a4e535b
DIST llfuse-0.43.tar.bz2 323979 SHA256 550c23c99ab1da711e816bdd980d588de174e143bc96cdb1f11c6ae6af35c7a1 SHA512 d3dfd33898eefd5774d007c960ac72f6c7a509ad18b5fb520a07f8c9b23414ba3f171e7d36a8703cdb2421270c3a3da82626cb6be7eb0cb3840d29506926c73f WHIRLPOOL 07b9e181f48d2f6d512436c775011b81f5db2e144809c9010e3a6cb263be75ebea1bebac7ecd02e242214b31feb18bafc0b996d36b257db152762769bdb5f127
+DIST llfuse-1.0.tar.bz2 323706 SHA256 fa521ce77a8c0ac1c8c21e6d4b0705dacc0ddd627439c2b3827c674909c027d2 SHA512 17d5fc91083dc29b11120980b68d000605582a757bf61a09ce4b840105fe0dc2b6afa416d09bf2abf11fd3c8bcbd5dfa4d90a9c9cc955c80a38111fb594e8b06 WHIRLPOOL aa8d22d0e7c6f5121c981c3c4fe7999aada35fa3bd5189c1ea14715366880af40105e8c35b4da7a098df449b277761a8dc50c489e65a074de430227599f032ac
diff --git a/dev-python/llfuse/llfuse-1.0.ebuild b/dev-python/llfuse/llfuse-1.0.ebuild
new file mode 100644
index 000000000000..37a7e75afc58
--- /dev/null
+++ b/dev-python/llfuse/llfuse-1.0.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3,3_4,3_5} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for the low-level FUSE API"
+HOMEPAGE="https://python-llfuse.googlecode.com/ https://pypi.python.org/pypi/llfuse"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+
+RDEPEND=">=sys-fs/fuse-2.8.0
+ $(python_gen_cond_dep 'dev-python/contextlib2[${PYTHON_USEDEP}]' python2_7)"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ virtual/pkgconfig
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ py.test || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/html/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}