summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2015-08-24 22:45:21 -0400
committerTim Harder <radhermit@gentoo.org>2015-08-24 22:45:21 -0400
commit23093edfc206367d290449f96f879d5bdd31e1d7 (patch)
treef0ea07feb8745e6da878f52bd4b8510462e969b0 /dev-python/llfuse
parentwww-apps/wordpress: version bump (diff)
downloadgentoo-23093edfc206367d290449f96f879d5bdd31e1d7.tar.gz
gentoo-23093edfc206367d290449f96f879d5bdd31e1d7.tar.bz2
gentoo-23093edfc206367d290449f96f879d5bdd31e1d7.zip
dev-python/llfuse: version bump
Diffstat (limited to 'dev-python/llfuse')
-rw-r--r--dev-python/llfuse/Manifest1
-rw-r--r--dev-python/llfuse/llfuse-0.41.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/llfuse/Manifest b/dev-python/llfuse/Manifest
index 8caa5844e344..0ff80c09134e 100644
--- a/dev-python/llfuse/Manifest
+++ b/dev-python/llfuse/Manifest
@@ -1,2 +1,3 @@
DIST llfuse-0.39.tar.bz2 250931 SHA256 4d9029efd461b7da099904d1cba193bd11964613263c38e97e9027174424995c SHA512 e75b4f22b256c05473531c6ee2aebcfd001cfb1f55e54c1f11405b3a958c1845912660e107adcc2b785dbb3fd54f683b7a6695cc33e0b53a563fad019b5e703a WHIRLPOOL 91b3ab7ce5fe6b1aebf78e9bf16d06995920fab30e79ce5006a2077663ae56b180c28939ba15d0599a4eec833a9c361bacfe8f8b9becff5a9a57cc7cce7746a1
DIST llfuse-0.40.tar.bz2 454032 SHA256 ee8b1125a6f2ab904d617d7602d86c0e3f69e40316cb1ae3abc33c218d3da857 SHA512 b568d14e181c316d592d01b7879d2b04c717759124d9462b7f848c251322a6a376881050d209d4cf3d0d6c5218ec1880cb64f19bd64b73f09fd06818447f3dfd WHIRLPOOL 3cfcd75a41ab39036b867e625248472a709ffdc61a588cbac47572455a6e3029f3d6592cbeb8e2b555a8c6f59729587a54c3373d3053e20f71a9b4f747ab87dc
+DIST llfuse-0.41.tar.bz2 397155 SHA256 58079acce2ed03305bfea998cfad7c5d1815c85c263e0a21f692d4cdb7d01bde SHA512 5c8bd2cf4bb5dec624fa3aa96aeadd2583cdfa45a9331d62e395ca2007c96f8ae667dba40568e1a17f30157b1d0ca123fe68639d78d117cd83c2405649bf166d WHIRLPOOL da876ab8502682cf77e711e9d2d8be5e74e6aa0d8bc639e7b55afa2f76d15173e5651706310b3814ef3a820c6afe45a50134cfa61e5db93fab452c222ef9394b
diff --git a/dev-python/llfuse/llfuse-0.41.ebuild b/dev-python/llfuse/llfuse-0.41.ebuild
new file mode 100644
index 000000000000..1b07f647a9c0
--- /dev/null
+++ b/dev-python/llfuse/llfuse-0.41.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for the low-level FUSE API"
+HOMEPAGE="https://python-llfuse.googlecode.com/ https://pypi.python.org/pypi/llfuse"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples"
+
+RDEPEND=">=sys-fs/fuse-2.8.0"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ virtual/pkgconfig"
+
+python_prepare_all() {
+ # use system setuptools
+ sed -i '/use_setuptools/d' setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/html/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}