summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-09-21 01:58:05 -0400
committerTim Harder <radhermit@gentoo.org>2017-09-21 02:00:40 -0400
commitec420564f81bc8988ca647f5358a21b58258b984 (patch)
tree6e86c5c32a4f27f3cc07d3ab710fa74b437971b6 /dev-python/llfuse
parentdev-ruby/ffaker: add 2.7.0 (diff)
downloadgentoo-ec420564f81bc8988ca647f5358a21b58258b984.tar.gz
gentoo-ec420564f81bc8988ca647f5358a21b58258b984.tar.bz2
gentoo-ec420564f81bc8988ca647f5358a21b58258b984.zip
dev-python/llfuse: version bump to 1.3
Diffstat (limited to 'dev-python/llfuse')
-rw-r--r--dev-python/llfuse/Manifest1
-rw-r--r--dev-python/llfuse/files/llfuse-1.3-cflags.patch19
-rw-r--r--dev-python/llfuse/llfuse-1.3.ebuild41
3 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/llfuse/Manifest b/dev-python/llfuse/Manifest
index 347aec10c8ff..61e68e535123 100644
--- a/dev-python/llfuse/Manifest
+++ b/dev-python/llfuse/Manifest
@@ -1 +1,2 @@
DIST llfuse-1.2.tar.bz2 327967 SHA256 24d3ff1dd793db0c03cbbfb298df94a369ecdce5831f8f175ec12d647ad01586 SHA512 0c31ac385a98211f8696857654ea187c5f18b655b65199696923bcc66d079a5e2a6f7260ac4f6da17b25ed57c9cb1314ce62fabb3b538a87e4286bbd0763390b WHIRLPOOL c3c2d2cc022f6aeafc3b167e6ce4c0e8e3a2c6b302e1f9fd0bdbcfd48bf92415b41d333cb4d02f186fee2308fec9a9fa633608353190bedb39321636cd5b9c5a
+DIST llfuse-1.3.tar.bz2 335418 SHA256 d1ab2c7cdaeed1c4c99882f2ad44df3906db263b832d76de18291e484c685bd2 SHA512 10d6c6dba20031106334559bd84d9477db70cf5e940f5e379716af1140bacaa4defe533cca51ac718e4d37b44414e34c7dcf48274c6fdd8ecc422f2f438552ee WHIRLPOOL ff0ab29ed312e788365da421b9f40b56edfad9cd6df5024351b29f46d41ab57844e98a9b7a4dc5e4bd157b50cc1ba8dfa7933d55f617ace3ee6ee19aa61232e0
diff --git a/dev-python/llfuse/files/llfuse-1.3-cflags.patch b/dev-python/llfuse/files/llfuse-1.3-cflags.patch
new file mode 100644
index 000000000000..42e4eef82a02
--- /dev/null
+++ b/dev-python/llfuse/files/llfuse-1.3-cflags.patch
@@ -0,0 +1,19 @@
+Build fails under pypy(3) when enabling these flags.
+
+--- llfuse-1.3/setup.py
++++ llfuse-1.3/setup.py
+@@ -84,12 +84,12 @@
+ compile_args.append('-Wno-unused-parameter')
+
+ # Value-changing conversions should always be explicit.
+- compile_args.append('-Werror=conversion')
++ # compile_args.append('-Werror=conversion')
+
+ # Note that (i > -1) is false if i is unsigned (-1 will be converted to
+ # a large positive value). We certainly don't want to do this by
+ # accident.
+- compile_args.append('-Werror=sign-compare')
++ # compile_args.append('-Werror=sign-compare')
+
+ # Enable all fatal warnings only when compiling from Mercurial tip.
+ # (otherwise we break forward compatibility because compilation with newer
diff --git a/dev-python/llfuse/llfuse-1.3.ebuild b/dev-python/llfuse/llfuse-1.3.ebuild
new file mode 100644
index 000000000000..761de45bf852
--- /dev/null
+++ b/dev-python/llfuse/llfuse-1.3.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} pypy{,3} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for the low-level FUSE API"
+HOMEPAGE="https://bitbucket.org/nikratio/python-llfuse/ https://pypi.python.org/pypi/llfuse"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+
+RDEPEND=">=sys-fs/fuse-2.8.0:0
+ $(python_gen_cond_dep 'dev-python/contextlib2[${PYTHON_USEDEP}]' python2_7 pypy)
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ virtual/pkgconfig
+ test? (
+ ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-catchlog[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=( "${FILESDIR}"/${P}-cflags.patch )
+
+python_test() {
+ py.test -v || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/html/. )
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}