summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-11-28 10:23:38 +0100
committerJustin Lecher <jlec@gentoo.org>2015-11-28 10:23:38 +0100
commitea5af051397c7bdc91e5350a52204ccb188be3e8 (patch)
tree3e4451c084cd0d5c4645d2679bfe515a78d4f03c /dev-python/lockfile
parentdev-python/py: Version Bump (diff)
downloadgentoo-ea5af051397c7bdc91e5350a52204ccb188be3e8.tar.gz
gentoo-ea5af051397c7bdc91e5350a52204ccb188be3e8.tar.bz2
gentoo-ea5af051397c7bdc91e5350a52204ccb188be3e8.zip
dev-python/lockfile: Version Bump
Package-Manager: portage-2.2.25 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/lockfile')
-rw-r--r--dev-python/lockfile/Manifest1
-rw-r--r--dev-python/lockfile/lockfile-0.12.2.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/lockfile/Manifest b/dev-python/lockfile/Manifest
index 4be3a3cccd35..7758b6fdbd0b 100644
--- a/dev-python/lockfile/Manifest
+++ b/dev-python/lockfile/Manifest
@@ -1 +1,2 @@
DIST lockfile-0.11.0.tar.gz 20909 SHA256 eed7e0c829135aaaf2a9df83652bc6e2cc50175d933741c25aac0394674e7fd3 SHA512 6c4c69e1434194076a99f8134a2558c791675d420a17687dfd5b38c1303564392ecc388ec285d55a20027bcbcbc1b3475a489b70390796c46346b89d4b18ad89 WHIRLPOOL 3fe41cec5f22109ce17e249a02469201e74cc6facd18bbcd5d6b75984f1f72e66d36eab68772d9bc6aa0c1ef6597f3bdf8f8757d9f867323d152cca8a47a445f
+DIST lockfile-0.12.2.tar.gz 20874 SHA256 6aed02de03cba24efabcd600b30540140634fc06cfa603822d508d5361e9f799 SHA512 67b7d651d7e963a497c2604912c61eed90181cdd09c744a0ceaa26e6bbe09d1a871ce48be3949b7da7ea6b366b15492c8c8de589edeca2641ca5e6cb3804df07 WHIRLPOOL a8aeb69cfeb0c190885fce7198ebfdb898b361806816a3b902e8764ad909cec8497dc5f09004bec2c0bbc6a88c057a4104e9a40e93fd25bb32437f4b63de491a
diff --git a/dev-python/lockfile/lockfile-0.12.2.ebuild b/dev-python/lockfile/lockfile-0.12.2.ebuild
new file mode 100644
index 000000000000..8bb8576489cb
--- /dev/null
+++ b/dev-python/lockfile/lockfile-0.12.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Platform-independent file locking module"
+HOMEPAGE="https://launchpad.net/pylockfile https://pypi.python.org/pypi/lockfile"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="doc test"
+
+DEPEND="
+ >dev-python/pbr-1.8[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( dev-python/nose[${PYTHON_USEDEP}] )"
+RDEPEND=""
+
+DOCS=( ACKS AUTHORS ChangeLog README.rst RELEASE-NOTES )
+
+python_compile_all() {
+ if use doc; then
+ einfo "Generation of documentation"
+ emake -C doc/source html || die "Generation of documentation failed"
+ fi
+}
+
+python_test() {
+ # "${PYTHON}" test/test_lockfile.py yeilds no informative coverage output
+ nosetests --verbose || die "test_lockfile failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/source/.build/html/. )
+ distutils-r1_python_install_all
+}