summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-01-03 21:04:43 +0100
committerPatrick Lauer <patrick@gentoo.org>2016-01-03 21:04:43 +0100
commitfd6fd755513759e00857255faa2d8fce7e5f1662 (patch)
tree0442551d02ea5bb45ad02c5b4c91b5e5ba72cca2 /dev-python/logbook/logbook-0.12.3.ebuild
parentdev-python/bcolz: Bump (diff)
downloadgentoo-fd6fd755513759e00857255faa2d8fce7e5f1662.tar.gz
gentoo-fd6fd755513759e00857255faa2d8fce7e5f1662.tar.bz2
gentoo-fd6fd755513759e00857255faa2d8fce7e5f1662.zip
dev-python/logbook: Bump
Package-Manager: portage-2.2.26
Diffstat (limited to 'dev-python/logbook/logbook-0.12.3.ebuild')
-rw-r--r--dev-python/logbook/logbook-0.12.3.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/logbook/logbook-0.12.3.ebuild b/dev-python/logbook/logbook-0.12.3.ebuild
new file mode 100644
index 000000000000..a86c3ef1c6bc
--- /dev/null
+++ b/dev-python/logbook/logbook-0.12.3.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="A logging replacement for Python"
+HOMEPAGE="http://packages.python.org/Logbook/ https://pypi.python.org/pypi/Logbook"
+SRC_URI="https://github.com/mitsuhiko/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+DISTUTILS_IN_SOURCE_BUILD=1
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )
+ doc? ( >=dev-python/sphinx-1.1.3-r3[${PYTHON_USEDEP}] )"
+RDEPEND="
+ dev-python/redis-py[${PYTHON_USEDEP}]
+ >=dev-python/six-1.4.0[${PYTHON_USEDEP}]"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.4.2-objectsinv.patch )
+
+python_prepare_all() {
+ # Delete test file requiring local conncetion to redis server
+ rm tests/test_queues.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ py.test tests || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}