summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Zuber <a.zuber@gmx.ch>2020-04-24 11:06:07 +0200
committerMichał Górny <mgorny@gentoo.org>2020-04-27 10:33:02 +0200
commit50cba45c044f6c45e0426381ab4427caa6a47854 (patch)
tree692ab889910b69e966ec03bd70beaf2c605482b2 /dev-python/logbook/logbook-1.5.3.ebuild
parentdev-python/wsproto: Bump to 0.15.0 (diff)
downloadgentoo-50cba45c044f6c45e0426381ab4427caa6a47854.tar.gz
gentoo-50cba45c044f6c45e0426381ab4427caa6a47854.tar.bz2
gentoo-50cba45c044f6c45e0426381ab4427caa6a47854.zip
dev-python/logbook: version bump to 1.5.3
Closes: https://bugs.gentoo.org/707804 Closes: https://bugs.gentoo.org/719082 Package-Manager: Portage-2.3.89, Repoman-2.3.20 Signed-off-by: Andreas Zuber <a.zuber@gmx.ch> Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/logbook/logbook-1.5.3.ebuild')
-rw-r--r--dev-python/logbook/logbook-1.5.3.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/logbook/logbook-1.5.3.ebuild b/dev-python/logbook/logbook-1.5.3.ebuild
new file mode 100644
index 000000000000..61013032e7e5
--- /dev/null
+++ b/dev-python/logbook/logbook-1.5.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="A logging replacement for Python"
+HOMEPAGE="https://logbook.readthedocs.io/en/stable/
+ https://github.com/getlogbook/logbook
+ https://pypi.org/project/Logbook/"
+SRC_URI="https://github.com/getlogbook/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+BDEPEND="
+ test? (
+ app-arch/brotli[${PYTHON_USEDEP},python]
+ dev-python/execnet[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/pyzmq[${PYTHON_USEDEP}]
+ dev-python/sqlalchemy[${PYTHON_USEDEP}]
+ )"
+RDEPEND="
+ !!dev-python/contextvars
+ !!dev-python/gevent"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs
+
+python_prepare_all() {
+ # Delete test file requiring local connection to redis server
+ rm tests/test_queues.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_configure_all() {
+ export DISABLE_LOGBOOK_CEXT=1
+}