summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2017-12-16 19:20:42 -0500
committerMike Gilbert <floppym@gentoo.org>2017-12-16 19:25:48 -0500
commitf958bb872acaeb7e8e6ca9e6cb8220946fa71def (patch)
treec660cac08d827aa5ecd258bd74689474daa2f2c8 /dev-python/logilab-common
parentsys-devel/gcc-config: Version bump; fixes prefix issues (bug 641096) and adds... (diff)
downloadgentoo-f958bb872acaeb7e8e6ca9e6cb8220946fa71def.tar.gz
gentoo-f958bb872acaeb7e8e6ca9e6cb8220946fa71def.tar.bz2
gentoo-f958bb872acaeb7e8e6ca9e6cb8220946fa71def.zip
dev-python/logilab-common: bump to 1.4.1
Bug: https://bugs.gentoo.org/641202 Package-Manager: Portage-2.3.19_p1, Repoman-2.3.6_p35
Diffstat (limited to 'dev-python/logilab-common')
-rw-r--r--dev-python/logilab-common/Manifest1
-rw-r--r--dev-python/logilab-common/logilab-common-1.4.1.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/logilab-common/Manifest b/dev-python/logilab-common/Manifest
index 9e820a404796..2be827897f5f 100644
--- a/dev-python/logilab-common/Manifest
+++ b/dev-python/logilab-common/Manifest
@@ -1 +1,2 @@
DIST logilab-common-1.2.2.tar.gz 184817 BLAKE2B 0318b4144150303b483fe921e01af326b55b7a3b93a014506685fde0b4e094a88efaaa70f63623264ee34fdfa72703e31cb0c8e9f4a69e309cab50997acae7ac SHA512 9c2161e8644e50cb3d4418430ca95363363e532b286d39cbdb73a51274bee02e5e8d0632b7564049243f497df96102c90ab0aeff9c91e91f7275407a6cfc56e2
+DIST logilab-common-1.4.1.tar.gz 185150 BLAKE2B 4c77b0a136a0de708801971f85b55fdd598767737ed17bc83ad1b934bcea5db67534370c202bc4b874ac774494ec6295a2458a7ae39fae36a9d5b482bce65563 SHA512 e016aa8bd8641b4178aa1d1dd58c8c78bf6c3a80c35c9096d9761eeb49c9ee1ab5952839a1b7ecc404cd60b31078d3e997d73ad4f8d07d88badffe6c8748a059
diff --git a/dev-python/logilab-common/logilab-common-1.4.1.ebuild b/dev-python/logilab-common/logilab-common-1.4.1.ebuild
new file mode 100644
index 000000000000..0946300f51c2
--- /dev/null
+++ b/dev-python/logilab-common/logilab-common-1.4.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Useful miscellaneous modules used by Logilab projects"
+HOMEPAGE="http://www.logilab.org/project/logilab-common https://pypi.python.org/pypi/logilab-common"
+SRC_URI="ftp://ftp.logilab.org/pub/common/${P}.tar.gz mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="test"
+
+RDEPEND=">=dev-python/six-1.4.0[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? (
+ $(python_gen_cond_dep 'dev-python/egenix-mx-base[${PYTHON_USEDEP}]' python2_7)
+ dev-python/pytz[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ # https://www.logilab.org/ticket/149345
+ # Prevent timezone related failure.
+ export TZ=UTC
+
+ ${EPYTHON} bin/logilab-pytest || die "Tests fail with ${EPYTHON}"
+}
+
+python_install() {
+ distutils-r1_python_install
+
+ # this package is commonly used by all logilab.* in ::gentoo,
+ # so let's just keep the namespace here
+ python_moduleinto logilab
+ python_domodule logilab/__init__.py
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ doman doc/logilab-pytest.1
+ find "${D}" -name '*.pth' -delete || die
+}