summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2016-06-29 15:26:47 +0200
committerPatrick Lauer <patrick@gentoo.org>2016-06-29 18:02:25 +0200
commitacf5be92ebd8075db33638e65673869c1dabe9ff (patch)
tree48f40da8c1a81980fa9cc207bdd0cb17b6130046 /dev-python/lz4/lz4-0.8.2.ebuild
parentprofiles: mask kde-apps/mplayerthumbs for removal (diff)
downloadgentoo-acf5be92ebd8075db33638e65673869c1dabe9ff.tar.gz
gentoo-acf5be92ebd8075db33638e65673869c1dabe9ff.tar.bz2
gentoo-acf5be92ebd8075db33638e65673869c1dabe9ff.zip
dev-python/lz4: Bump
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python/lz4/lz4-0.8.2.ebuild')
-rw-r--r--dev-python/lz4/lz4-0.8.2.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/lz4/lz4-0.8.2.ebuild b/dev-python/lz4/lz4-0.8.2.ebuild
new file mode 100644
index 000000000000..57032f96e888
--- /dev/null
+++ b/dev-python/lz4/lz4-0.8.2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="LZ4 Bindings for Python"
+HOMEPAGE="https://pypi.python.org/pypi/lz4 https://github.com/steeve/python-lz4"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+# Tests still excluded by upstream
+
+python_prepare_all() {
+ sed \
+ -e '/nose/s:setup_requires:test_requires:g' \
+ -i setup.py || die
+ distutils-r1_python_prepare_all
+}