summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorZamarin Arthur <arthurzam@gmail.com>2019-03-10 08:02:24 +0200
committerPatrice Clement <monsieurp@gentoo.org>2019-03-11 23:26:30 +0100
commit0dc8b7dbdeecc1dac7165dca6e6b46777f863b38 (patch)
treeb5127c64784b261e629a9ea9aeb59d2fa5d33fc7 /dev-python/lz4/lz4-2.1.6.ebuild
parentgnome-base/nautilus: bump to 3.30.5 (diff)
downloadgentoo-0dc8b7dbdeecc1dac7165dca6e6b46777f863b38.tar.gz
gentoo-0dc8b7dbdeecc1dac7165dca6e6b46777f863b38.tar.bz2
gentoo-0dc8b7dbdeecc1dac7165dca6e6b46777f863b38.zip
dev-python/lz4: version 2.1.6 bump.
Closes: https://bugs.gentoo.org/663570 Signed-off-by: Zamarin Arthur <arthurzam@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/11324 Signed-off-by: Patrice Clement <monsieurp@gentoo.org>
Diffstat (limited to 'dev-python/lz4/lz4-2.1.6.ebuild')
-rw-r--r--dev-python/lz4/lz4-2.1.6.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/lz4/lz4-2.1.6.ebuild b/dev-python/lz4/lz4-2.1.6.ebuild
new file mode 100644
index 000000000000..b1f535b1d153
--- /dev/null
+++ b/dev-python/lz4/lz4-2.1.6.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2019 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python{2_7,3_5,3_6,3_7} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="LZ4 Bindings for Python"
+HOMEPAGE="https://pypi.org/project/lz4/ https://github.com/python-lz4/python-lz4"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="BSD"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="app-arch/lz4"
+DEPEND="
+ ${RDEPEND}
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/pkgconfig[${PYTHON_USEDEP}]
+"