summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2016-04-03 22:59:32 +0200
committerManuel Rüger <mrueg@gentoo.org>2016-04-03 22:59:32 +0200
commitc3237da4c0d0a996976aac59e0428559151e683a (patch)
treeac95b2944218afb637a9e567d71bc7c298a9d368 /dev-python/m2crypto/m2crypto-0.24.0.ebuild
parentdev-python/setuptools: Version bump to 20.6.7 (diff)
downloadgentoo-c3237da4c0d0a996976aac59e0428559151e683a.tar.gz
gentoo-c3237da4c0d0a996976aac59e0428559151e683a.tar.bz2
gentoo-c3237da4c0d0a996976aac59e0428559151e683a.zip
dev-python/m2crypto: Version bump to 0.24.0
Package-Manager: portage-2.2.28
Diffstat (limited to 'dev-python/m2crypto/m2crypto-0.24.0.ebuild')
-rw-r--r--dev-python/m2crypto/m2crypto-0.24.0.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/m2crypto/m2crypto-0.24.0.ebuild b/dev-python/m2crypto/m2crypto-0.24.0.ebuild
new file mode 100644
index 000000000000..132a4997ff9f
--- /dev/null
+++ b/dev-python/m2crypto/m2crypto-0.24.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+MY_PN="M2Crypto"
+
+DESCRIPTION="M2Crypto: A Python crypto and SSL toolkit"
+HOMEPAGE="https://github.com/martinpaljak/M2Crypto https://pypi.python.org/pypi/M2Crypto"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="libressl"
+
+RDEPEND="
+ !libressl? ( >=dev-libs/openssl-0.9.8:0= )
+ libressl? ( dev-libs/libressl:= )
+"
+DEPEND="${RDEPEND}
+ >=dev-lang/swig-1.3.28:0
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+# Tests access network, and fail randomly. Bug #431458.
+RESTRICT=test
+
+python_test() {
+ esetup.py test
+}