summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-23 13:00:33 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-23 13:00:33 +0200
commitc5122174ac31b49c4dd99b4cb05e826c3108d1f3 (patch)
treed469c714b036c7e2af6cef45c1dfeffd67e91264 /dev-python/mando
parentdev-python/liblarch: Enable py3.9 (diff)
downloadgentoo-c5122174ac31b49c4dd99b4cb05e826c3108d1f3.tar.gz
gentoo-c5122174ac31b49c4dd99b4cb05e826c3108d1f3.tar.bz2
gentoo-c5122174ac31b49c4dd99b4cb05e826c3108d1f3.zip
dev-python/mando: Enable py3.9 & py3.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/mando')
-rw-r--r--dev-python/mando/mando-0.6.4.ebuild28
1 files changed, 7 insertions, 21 deletions
diff --git a/dev-python/mando/mando-0.6.4.ebuild b/dev-python/mando/mando-0.6.4.ebuild
index ddd3921f30cf..87d54e40707e 100644
--- a/dev-python/mando/mando-0.6.4.ebuild
+++ b/dev-python/mando/mando-0.6.4.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{7,8} )
+PYTHON_COMPAT=( python3_{7..10} )
inherit distutils-r1
@@ -13,30 +13,16 @@ SRC_URI="https://github.com/rubik/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE="doc examples test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? (
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/coverage[${PYTHON_USEDEP}]
- dev-python/tox[${PYTHON_USEDEP}]
- )
-"
-RDEPEND=""
-
-python_compile_all() {
- use doc && emake -C docs html
-}
+IUSE="examples"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
python_test() {
- "${PYTHON}" mando/tests/run.py || die "tests failed under ${EPYTHON}"
+ "${EPYTHON}" mando/tests/run.py || die "tests failed under ${EPYTHON}"
}
python_install_all() {
- use doc && local HTML_DOCS=( docs/_build/html/. )
if use examples; then
dodoc -r examples
docompress -x /usr/share/doc/${PF}/examples