summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNils Freydank <holgersson@posteo.de>2018-10-27 19:54:05 +0200
committerMichał Górny <mgorny@gentoo.org>2018-10-30 10:07:33 +0100
commitf0ffb5105bdb78c21992efc167486e0491c2a424 (patch)
tree7b0ff1696ff11e2f08f01849fc426e003f0686e0 /dev-python/markdown/markdown-3.0.1.ebuild
parentdev-python/pytidylib: Bump to 0.3.2 and add python3_7 support (diff)
downloadgentoo-f0ffb5105bdb78c21992efc167486e0491c2a424.tar.gz
gentoo-f0ffb5105bdb78c21992efc167486e0491c2a424.tar.bz2
gentoo-f0ffb5105bdb78c21992efc167486e0491c2a424.zip
dev-python/markdown: Bump to 3.0.1 and add python3_7 support
Signed-off-by: Nils Freydank <holgersson@posteo.de> Package-Manager: Portage-2.3.51, Repoman-2.3.11 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/markdown/markdown-3.0.1.ebuild')
-rw-r--r--dev-python/markdown/markdown-3.0.1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/markdown/markdown-3.0.1.ebuild b/dev-python/markdown/markdown-3.0.1.ebuild
new file mode 100644
index 000000000000..3efa195b8f52
--- /dev/null
+++ b/dev-python/markdown/markdown-3.0.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6,7} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python implementation of the markdown markup language"
+HOMEPAGE="
+ https://python-markdown.github.io/
+ https://pypi.org/project/Markdown/
+ https://github.com/Python-Markdown/markdown"
+SRC_URI="mirror://pypi/M/${PN^}/${P^}.tar.gz"
+
+LICENSE="|| ( BSD GPL-2 )"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE="doc test pygments"
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ dev-python/pytidylib[${PYTHON_USEDEP}]
+ )"
+# source cites pytidylib however from testruns it appears optional
+RDEPEND="pygments? ( dev-python/pygments[${PYTHON_USEDEP}] )"
+
+S="${WORKDIR}/${P^}"
+
+PATCHES=()
+
+python_compile_all() {
+ if use doc; then
+ esetup.py build_docs
+ HTML_DOCS=( "${BUILD_DIR}"/docs/. )
+
+ # remove .txt files
+ find "${BUILD_DIR}"/docs -name '*.txt' -delete || die
+ fi
+}
+
+python_test() {
+ esetup.py test
+}