summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/markdown2
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/markdown2')
-rw-r--r--dev-python/markdown2/Manifest3
-rw-r--r--dev-python/markdown2/markdown2-2.2.1.ebuild32
-rw-r--r--dev-python/markdown2/markdown2-2.2.3.ebuild32
-rw-r--r--dev-python/markdown2/markdown2-2.3.0.ebuild33
-rw-r--r--dev-python/markdown2/metadata.xml18
5 files changed, 118 insertions, 0 deletions
diff --git a/dev-python/markdown2/Manifest b/dev-python/markdown2/Manifest
new file mode 100644
index 000000000000..c4701abe248c
--- /dev/null
+++ b/dev-python/markdown2/Manifest
@@ -0,0 +1,3 @@
+DIST markdown2-2.2.1.zip 138508 SHA256 1e529b016e094402ba1a632f9db77eb168cd085d7cb81309a55b33c3e72999b9 SHA512 a97fbb80c7b7b7ebc7e3048e1eecc97f3df8052db4f5e7cf38b4f8e170c102dfe732070bcfe85de0331a27af8ea9fa4be81c7b80f37f3cbd5b11acc0489f1561 WHIRLPOOL 318a97e4a91d6054d3de6479f6ea5cd93a2f56f3e5e732bed70547e7594e11ffce3cb927e34530a79ed5996caf7900959f15da66ad1d1f12a3235ead6d9d39d8
+DIST markdown2-2.2.3.zip 142502 SHA256 30a5c7e814e0011b8a60e2efefc375af0734c36ed5acf2b971d0f446588850bf SHA512 2aed0cce3ed3c1d3e52d4836d296d56a16a7652f1cf5d19cbb4a1bb800424abd2f068655f06d9c4fc00fede312710d7ed558d71864cd3090ae0703d1e74bb8a1 WHIRLPOOL 94a0f3bc41919dad042a1c8ce06858b1c9be49c6159ccb26ed608279e39b6dc223911700d5776ce7b02197c4397ee66af92e0c4de49144bf242b538cadee2919
+DIST markdown2-2.3.0.zip 145194 SHA256 c8e29ba47a0e408bb92df75d5c6361c84268c54c5320d53ffd4961c546f77f1c SHA512 48bf8e26b34c48c0c12fc0f110b09d3232ea3394db3325d50639adf5cefb603344ee97b116e09b574f7c7414ab4a8293ddc37ca6706e41baaa14e399fa467d5f WHIRLPOOL 1ca759c7f08437d98304849de2259576fbb813845dee5282a54e0a8940b2b76ba9dd31912894ac63f336f1aecaa00a566c39d87ddcc48d11daee3f981fd933a0
diff --git a/dev-python/markdown2/markdown2-2.2.1.ebuild b/dev-python/markdown2/markdown2-2.2.1.ebuild
new file mode 100644
index 000000000000..c31b424ceb1c
--- /dev/null
+++ b/dev-python/markdown2/markdown2-2.2.1.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python Markdown language reimplementation"
+SRC_URI="mirror://pypi/m/markdown2/${P}.zip"
+HOMEPAGE="http://github.com/trentm/python-markdown2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="dev-python/pygments[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+python_prepare_all() {
+ rm -f test/tm-cases/issue52* || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ cd test || die
+ "${PYTHON}" test.py || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/markdown2/markdown2-2.2.3.ebuild b/dev-python/markdown2/markdown2-2.2.3.ebuild
new file mode 100644
index 000000000000..3c98cc58cee1
--- /dev/null
+++ b/dev-python/markdown2/markdown2-2.2.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python Markdown language reimplementation"
+SRC_URI="mirror://pypi/m/markdown2/${P}.zip"
+HOMEPAGE="http://github.com/trentm/python-markdown2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="dev-python/pygments[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+python_prepare_all() {
+ rm -f test/tm-cases/issue52* || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ cd test || die
+ "${PYTHON}" test.py || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/markdown2/markdown2-2.3.0.ebuild b/dev-python/markdown2/markdown2-2.3.0.ebuild
new file mode 100644
index 000000000000..8d34b7bad44c
--- /dev/null
+++ b/dev-python/markdown2/markdown2-2.3.0.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Python Markdown language reimplementation"
+SRC_URI="mirror://pypi/m/markdown2/${P}.zip"
+HOMEPAGE="http://github.com/trentm/python-markdown2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+DEPEND="dev-python/pygments[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+
+python_prepare_all() {
+ # [issue52, knownfailure]
+ rm -f test/tm-cases/issue52* || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ cd test || die
+ "${PYTHON}" test.py || die "Tests fail with ${EPYTHON}"
+}
diff --git a/dev-python/markdown2/metadata.xml b/dev-python/markdown2/metadata.xml
new file mode 100644
index 000000000000..6031ef0e9e7a
--- /dev/null
+++ b/dev-python/markdown2/metadata.xml
@@ -0,0 +1,18 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>maksbotan@gentoo.org</email>
+ <name>Maxim Koltsov</name>
+ </maintainer>
+ <upstream>
+ <maintainer>
+ <email/>
+ <name>Trent Mick</name>
+ </maintainer>
+ <bugs-to>http://github.com/trentm/python-markdown2/issues</bugs-to>
+ <remote-id type="pypi">markdown2</remote-id>
+ <remote-id type="github">trentm/python-markdown2</remote-id>
+ </upstream>
+</pkgmetadata>