summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2020-03-30 14:26:52 -0700
committerPatrick McLean <chutzpah@gentoo.org>2020-03-30 14:27:14 -0700
commite492ddc1f20ab5d4c885854a5a03b2248a0219e4 (patch)
tree341f6a08a9b9de0eb37694f7da670dac3614d4a2 /dev-python/marshmallow/marshmallow-3.5.1.ebuild
parentdev-python/webtest: stable 2.0.33 for sparc, bug #715302 (diff)
downloadgentoo-e492ddc1f20ab5d4c885854a5a03b2248a0219e4.tar.gz
gentoo-e492ddc1f20ab5d4c885854a5a03b2248a0219e4.tar.bz2
gentoo-e492ddc1f20ab5d4c885854a5a03b2248a0219e4.zip
dev-python/marshmallow-3.5.1: version bump, add py38
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.96, Repoman-2.3.22 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/marshmallow/marshmallow-3.5.1.ebuild')
-rw-r--r--dev-python/marshmallow/marshmallow-3.5.1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/marshmallow/marshmallow-3.5.1.ebuild b/dev-python/marshmallow/marshmallow-3.5.1.ebuild
new file mode 100644
index 000000000000..37a0ebcd4cc9
--- /dev/null
+++ b/dev-python/marshmallow/marshmallow-3.5.1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="A lightweight library for converting complex datatypes to and from native Python datatypes."
+HOMEPAGE="https://github.com/marshmallow-code/marshmallow/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest