summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2019-05-02 11:10:35 -0400
committerVirgil Dupras <vdupras@gentoo.org>2019-05-02 11:10:35 -0400
commit3017cf5138cdd90bda307ad0e820e5890350738a (patch)
treef0ede57478faddf92ce6ce628e03fa5a7cda6615 /dev-python/matplotlib/files
parentdev-python/numpydoc: add version 0.8.0 (diff)
downloadgentoo-3017cf5138cdd90bda307ad0e820e5890350738a.tar.gz
gentoo-3017cf5138cdd90bda307ad0e820e5890350738a.tar.bz2
gentoo-3017cf5138cdd90bda307ad0e820e5890350738a.zip
dev-python/matplotlib: bump to 2.2.4
Closes: https://bugs.gentoo.org/684798 Closes: https://bugs.gentoo.org/656262 Signed-off-by: Virgil Dupras <vdupras@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'dev-python/matplotlib/files')
-rw-r--r--dev-python/matplotlib/files/matplotlib-2.2.4-doc-fix.patch18
-rw-r--r--dev-python/matplotlib/files/matplotlib-2.2.4-no-jqueryui-download.patch18
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/matplotlib/files/matplotlib-2.2.4-doc-fix.patch b/dev-python/matplotlib/files/matplotlib-2.2.4-doc-fix.patch
new file mode 100644
index 000000000000..b6a01b097a61
--- /dev/null
+++ b/dev-python/matplotlib/files/matplotlib-2.2.4-doc-fix.patch
@@ -0,0 +1,18 @@
+diff --git a/doc/conf.py b/doc/conf.py
+index 017ce210e..5a397082b 100644
+--- a/doc/conf.py
++++ b/doc/conf.py
+@@ -170,10 +170,10 @@ source_encoding = "utf-8"
+ master_doc = 'contents'
+
+ # General substitutions.
+-from matplotlib.compat.subprocess import check_output
+-SHA = check_output(['git', 'describe', '--dirty']).decode('utf-8').strip()
++#from matplotlib.compat.subprocess import check_output
++#SHA = check_output(['git', 'describe', '--dirty']).decode('utf-8').strip()
+
+-html_context = {'sha': SHA}
++#html_context = {'sha': SHA}
+
+ project = 'Matplotlib'
+ copyright = ('2002 - 2012 John Hunter, Darren Dale, Eric Firing, '
diff --git a/dev-python/matplotlib/files/matplotlib-2.2.4-no-jqueryui-download.patch b/dev-python/matplotlib/files/matplotlib-2.2.4-no-jqueryui-download.patch
new file mode 100644
index 000000000000..9d13adb8ab53
--- /dev/null
+++ b/dev-python/matplotlib/files/matplotlib-2.2.4-no-jqueryui-download.patch
@@ -0,0 +1,18 @@
+diff --git a/setup.py b/setup.py
+index 41037e95d..6a438fa99 100644
+--- a/setup.py
++++ b/setup.py
+@@ -178,9 +178,10 @@ class sdist_with_jquery(_orgin_sdist):
+ class install_lib_with_jquery(InstallLibCommand):
+ def run(self):
+ InstallLibCommand.run(self)
+- _download_jquery_to(
+- os.path.join(self.install_dir, "matplotlib/backends/web_backend/"))
+-
++ # Avoid downloading jquery ui during emerge: we already have it in
++ # pypi's tarball. use this!
++ name = "matplotlib/backends/web_backend/jquery-ui-1.12.1"
++ os.rename(os.path.join('lib', name), os.path.join(self.install_dir, name))
+
+ class develop_with_jquery(DevelopCommand):
+ def run(self):