summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Brehler <marbre@linux.sungazer.de>2017-04-05 09:05:01 +0200
committerDavid Seifert <soap@gentoo.org>2017-04-16 21:05:26 +0200
commitbe14faad8b254b541f7e29d3b453f310c6297343 (patch)
tree3b513238eac7d3d6dc7f74fd2c443448513d842c /dev-python/matplotlib2tikz
parentdev-python/qtconsole: Version bump to 4.3.0 (diff)
downloadgentoo-be14faad8b254b541f7e29d3b453f310c6297343.tar.gz
gentoo-be14faad8b254b541f7e29d3b453f310c6297343.tar.bz2
gentoo-be14faad8b254b541f7e29d3b453f310c6297343.zip
dev-python/matplotlib2tikz: Version bump to 0.6.3
Package-Manager: Portage-2.3.3, Repoman-2.3.1 Closes: https://github.com/gentoo/gentoo/pull/4350
Diffstat (limited to 'dev-python/matplotlib2tikz')
-rw-r--r--dev-python/matplotlib2tikz/Manifest1
-rw-r--r--dev-python/matplotlib2tikz/matplotlib2tikz-0.6.3.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/matplotlib2tikz/Manifest b/dev-python/matplotlib2tikz/Manifest
index 1efb6a8c9999..53c2b77e9f3e 100644
--- a/dev-python/matplotlib2tikz/Manifest
+++ b/dev-python/matplotlib2tikz/Manifest
@@ -1 +1,2 @@
DIST matplotlib2tikz-0.6.2.tar.gz 26358 SHA256 a81b1a09e8c0efc9944d673023d3a8c14ca38aec04af487c427f20872555ff09 SHA512 b60f378f947ec51be82fc45dafad14ef2700babb2ec72886480aff9bd84d591bc15e0626f38018f2d351ab8293109b2fc12cc4912eb933528b5334b2ef8ecfb7 WHIRLPOOL befa7a990cc4246c2a3357c72b4c34ec76e44af905c0d19312eccbf5ce8e5c8742f906484214ab50466992ae3fed40c5ffbb84e8b80bb06cea830f892a9c947e
+DIST matplotlib2tikz-0.6.3.tar.gz 26288 SHA256 c096d75fdfe65ef4afd8aa374c5fb4b540fc13154d1ee117841ad5b67e494827 SHA512 01adffcd9d627494eb73e1f092e6ee3d6ad1b0ece96fb749a09c73942fc6a253abb3518dc8d11a2398c3fcb3b2c1e26b1dc5dc02f1e9671c4c12754f9ac6907b WHIRLPOOL 363a896f9fe5b648992767cb5449928e30141ed3aea5182a6c119af50f0793f7c0cb2e2d0daae3b4d78fb9c91af6c1ea0233f9407a0658d3be8dc1d76cf52151
diff --git a/dev-python/matplotlib2tikz/matplotlib2tikz-0.6.3.ebuild b/dev-python/matplotlib2tikz/matplotlib2tikz-0.6.3.ebuild
new file mode 100644
index 000000000000..e40f2b47df96
--- /dev/null
+++ b/dev-python/matplotlib2tikz/matplotlib2tikz-0.6.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Convert matplotlib figures into TikZ/PGFPlots"
+HOMEPAGE="https://github.com/nschloe/matplotlib2tikz"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+KEYWORDS="~amd64"
+
+LICENSE="MIT"
+SLOT="0"
+IUSE=""
+
+PATCHES=( "${FILESDIR}/${PN}-0.6-init_pipdated.patch" )
+
+RDEPEND="
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"