summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2016-02-07 11:17:35 +0100
committerJustin Lecher <jlec@gentoo.org>2016-02-07 13:00:00 +0100
commit9e2d0013b90eb3b1d00bbab12e46e8d62a5eb959 (patch)
treeaa000640acfdeb9e4115ab8ca525abfae075c997 /dev-python/maybe
parentdev-python/python-ptrace: Add python3.5 support (diff)
downloadgentoo-9e2d0013b90eb3b1d00bbab12e46e8d62a5eb959.tar.gz
gentoo-9e2d0013b90eb3b1d00bbab12e46e8d62a5eb959.tar.bz2
gentoo-9e2d0013b90eb3b1d00bbab12e46e8d62a5eb959.zip
dev-python/maybe: Add python3.5 support
Package-Manager: portage-2.2.27 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/maybe')
-rw-r--r--dev-python/maybe/Manifest1
-rw-r--r--dev-python/maybe/maybe-0.2.1.ebuild26
-rw-r--r--dev-python/maybe/metadata.xml15
3 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/maybe/Manifest b/dev-python/maybe/Manifest
new file mode 100644
index 000000000000..475b91934ce7
--- /dev/null
+++ b/dev-python/maybe/Manifest
@@ -0,0 +1 @@
+DIST maybe-0.2.1.tar.gz 5722 SHA256 d7286b458ad1eb2546401614871e8b2b5c34cd75b5ab95dde73db928c4eaa74f SHA512 490f1bc31f9f1cc196c4359292270724ececacde4ba2047b5b709a8d4713fa5a730fb6a39ed2c2f2073827e484992568f0a6630a0078be1bbe473568606f7479 WHIRLPOOL 806e2eee1a28468462857a940889d6981c0fb06d271ec59b1f367a2ffadfbbf12350009ec5b4ef3801a05aa50395fc8daf185cee1354d37bbedc55480aa144fc
diff --git a/dev-python/maybe/maybe-0.2.1.ebuild b/dev-python/maybe/maybe-0.2.1.ebuild
new file mode 100644
index 000000000000..b3387fd13ab9
--- /dev/null
+++ b/dev-python/maybe/maybe-0.2.1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{3,4,5}} )
+
+inherit distutils-r1
+
+DESCRIPTION="See what a program does before deciding whether you really want it to happen"
+HOMEPAGE="https://github.com/p-e-w/maybe http://pypi.python.org/pypi/maybe"
+SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="
+ dev-python/blessings[${PYTHON_USEDEP}]
+ dev-python/python-ptrace[${PYTHON_USEDEP}]
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
diff --git a/dev-python/maybe/metadata.xml b/dev-python/maybe/metadata.xml
new file mode 100644
index 000000000000..12837efea8ba
--- /dev/null
+++ b/dev-python/maybe/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">maybe</remote-id>
+ <maintainer status="unknown">
+ <email>pew@worldwidemann.com</email>
+ <name>Philipp Emanuel Weidmann</name>
+ </maintainer>
+ </upstream>
+</pkgmetadata>