summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-05-24 14:04:55 +0200
committerAndrew Ammerlaan <andrewammerlaan@gentoo.org>2022-05-24 15:02:24 +0200
commit62b97e1e8ad26df59cc144bb6d170dbdaf4ffe7e (patch)
tree817a5eb7c7b3e3efe5c1c9f4f3a883cd20a43130 /dev-python/mdx_gh_links/mdx_gh_links-0.2-r1.ebuild
parentdev-python/mkdocs: enable py3.11, nose --> pytest (diff)
downloadgentoo-62b97e1e8ad26df59cc144bb6d170dbdaf4ffe7e.tar.gz
gentoo-62b97e1e8ad26df59cc144bb6d170dbdaf4ffe7e.tar.bz2
gentoo-62b97e1e8ad26df59cc144bb6d170dbdaf4ffe7e.zip
dev-python/mdx_gh_links: update EAPI 7 -> 8, enable py3.11, pep517
Signed-off-by: Andrew Ammerlaan <andrewammerlaan@gentoo.org>
Diffstat (limited to 'dev-python/mdx_gh_links/mdx_gh_links-0.2-r1.ebuild')
-rw-r--r--dev-python/mdx_gh_links/mdx_gh_links-0.2-r1.ebuild20
1 files changed, 20 insertions, 0 deletions
diff --git a/dev-python/mdx_gh_links/mdx_gh_links-0.2-r1.ebuild b/dev-python/mdx_gh_links/mdx_gh_links-0.2-r1.ebuild
new file mode 100644
index 000000000000..804f0cb29cea
--- /dev/null
+++ b/dev-python/mdx_gh_links/mdx_gh_links-0.2-r1.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+DESCRIPTION="An extension which adds links to GitHub users, repositories, issues and commits"
+HOMEPAGE="https://github.com/Python-Markdown/github-links"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/markdown[${PYTHON_USEDEP}]
+"