summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-24 22:40:21 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-24 23:00:02 +0100
commit1a3052c631a979d23c9fb91ce367a3b1c498b797 (patch)
tree14614be2cb2d3d991fc2358054b540dc85b84fad /dev-python/meshio
parentdev-python/s3transfer: Bump to 0.5.2 (diff)
downloadgentoo-1a3052c631a979d23c9fb91ce367a3b1c498b797.tar.gz
gentoo-1a3052c631a979d23c9fb91ce367a3b1c498b797.tar.bz2
gentoo-1a3052c631a979d23c9fb91ce367a3b1c498b797.zip
dev-python/meshio: Bump to 5.3.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/meshio')
-rw-r--r--dev-python/meshio/Manifest1
-rw-r--r--dev-python/meshio/meshio-5.3.2.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/meshio/Manifest b/dev-python/meshio/Manifest
index ad8706dcafa4..739f12db6010 100644
--- a/dev-python/meshio/Manifest
+++ b/dev-python/meshio/Manifest
@@ -1 +1,2 @@
DIST meshio-5.3.0.tar.gz 491246 BLAKE2B 0fd867c2ddabb29cd88dfdea1b5ef04ebf8d63ed957df5df7c426a00f0de409dcd556de4530dec91e71126671e7048af071f734e3d1c375fc67de0403edd7f37 SHA512 2304c75b74093120655cbfae6ec7b770de6bfdbe677c84e997449df91d7d3fd6b61c946d00bf57eba99e5812a08a032c55bf2d4c81316b356016d818b329f795
+DIST meshio-5.3.2.tar.gz 491651 BLAKE2B 537f76f7b69a64777b631344da4b6a3e1cee33be1df05726406aceeddb68ed6589abb210f30cb74dbd899688a417ec9140fa6d8a5f7eb94ce5d85e99f315a731 SHA512 91a5d6064b69b8e631a60c613e0b06e784b475c296cc9572d4f9111dac932b0e75cf7ef1e6849329354a9708de1d32bafc1b297297d94a5554962f6807123921
diff --git a/dev-python/meshio/meshio-5.3.2.ebuild b/dev-python/meshio/meshio-5.3.2.ebuild
new file mode 100644
index 000000000000..8a22053a774c
--- /dev/null
+++ b/dev-python/meshio/meshio-5.3.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="Input/output for many mesh formats"
+HOMEPAGE="https://github.com/nschloe/meshio"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="hdf5 netcdf"
+
+RDEPEND="
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/rich[${PYTHON_USEDEP}]
+ hdf5? ( dev-python/h5py[${PYTHON_USEDEP}] )
+ netcdf? ( dev-python/netcdf4-python[${PYTHON_USEDEP}] )
+"
+BDEPEND="
+ test? ( dev-python/h5py[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_tests pytest