summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sautier.louis@gmail.com>2016-03-29 14:03:25 +0200
committerIan Delaney <idella4@gentoo.org>2016-03-29 21:52:47 +0800
commit85dab0e18944605c7417a6f758edcf4f3021b910 (patch)
tree98d6be69890b90e32cb93c1668070ce344f52599 /dev-python/minidb/minidb-2.0.1.ebuild
parentwww-apps/airdcpp-webui: remove old (diff)
downloadgentoo-85dab0e18944605c7417a6f758edcf4f3021b910.tar.gz
gentoo-85dab0e18944605c7417a6f758edcf4f3021b910.tar.bz2
gentoo-85dab0e18944605c7417a6f758edcf4f3021b910.zip
dev-python/minidb: add missing PYTHON_REQ_USE, minor fixes
edit to vn. 2.0.1 Package-Manager: portage-2.2.28 Closes: https://github.com/gentoo/gentoo/pull/1160 Signed-off-by: Ian Delaney <idella4@gentoo.org>
Diffstat (limited to 'dev-python/minidb/minidb-2.0.1.ebuild')
-rw-r--r--dev-python/minidb/minidb-2.0.1.ebuild7
1 files changed, 3 insertions, 4 deletions
diff --git a/dev-python/minidb/minidb-2.0.1.ebuild b/dev-python/minidb/minidb-2.0.1.ebuild
index 0db93abdd757..c3097b05927f 100644
--- a/dev-python/minidb/minidb-2.0.1.ebuild
+++ b/dev-python/minidb/minidb-2.0.1.ebuild
@@ -2,15 +2,16 @@
# Distributed under the terms of the GNU General Public License v2
# $Id$
-EAPI=5
+EAPI=6
PYTHON_COMPAT=( python{3_4,3_5} )
+PYTHON_REQ_USE="sqlite"
inherit distutils-r1
DESCRIPTION="Simple SQLite-based object store"
HOMEPAGE="http://thp.io/2010/minidb/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${PN}-${PV}.tar.gz"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="ISC"
SLOT="0"
@@ -22,8 +23,6 @@ DEPEND="
test? ( dev-python/nose[${PYTHON_USEDEP}] )
"
-S="${WORKDIR}/${PN}-${PV}"
-
python_test() {
nosetests test || die "tests failed with ${EPYTHON}"
}