summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2020-05-03 22:41:37 +0200
committerLouis Sautier <sbraz@gentoo.org>2020-05-03 23:14:46 +0200
commit9141de6fb2f2573dfccd8bc862f01fed47356838 (patch)
treea2358260d712092a420c772d77ea453c124a8a22 /dev-python/minidb
parentmeson.eclass: export FLAGS for older versions on meson (diff)
downloadgentoo-9141de6fb2f2573dfccd8bc862f01fed47356838.tar.gz
gentoo-9141de6fb2f2573dfccd8bc862f01fed47356838.tar.bz2
gentoo-9141de6fb2f2573dfccd8bc862f01fed47356838.zip
dev-python/minidb: bump to 2.0.4, uses pytest instead of nose
Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python/minidb')
-rw-r--r--dev-python/minidb/Manifest1
-rw-r--r--dev-python/minidb/minidb-2.0.4.ebuild20
2 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/minidb/Manifest b/dev-python/minidb/Manifest
index d200f641992d..23e648bba2fd 100644
--- a/dev-python/minidb/Manifest
+++ b/dev-python/minidb/Manifest
@@ -1,2 +1,3 @@
DIST minidb-2.0.2.tar.gz 13928 BLAKE2B 7b6997bd0ed852561c1a45e1d8f63030798c59ebbe67ba3e9f38c08eddcf22028756b17c5ce8aa460e5d3113ef54cdafe782cb471aabfe208b093af702694cb7 SHA512 92879d6df61b0f9f72f9fe8f1cf38d559477983c6bba8c88ed02289570daff02f6f8d7010c0a95ffce049ab67be69323c47caefdfe3a8b008038377235ed9a5f
DIST minidb-2.0.3.tar.gz 13992 BLAKE2B 7ccb26625c199517ee63e99b1839037046c29a4c72a26f457ef3b4c22ef1f23b0bf632b37790c2981fd2c08929a39e8f015b4cf890d04d5e9926cd07b5def699 SHA512 90e2c51af64a373a9dce5e6fad94440a8e5ff3136ba4004deebb5f9a7a7f039ebf1b903a361d678771b6e18e951cacbd7392f1fe2df8db04cef04526a07a3ce2
+DIST minidb-2.0.4.tar.gz 14104 BLAKE2B 020996d1e83a84aad26d073b3fcf5161edc1698f0876e499b5dddf88bc5ad776d5203c9dfd49cb9651f66425dad5bf9b3a751940da2cb3f841157af23940ccb8 SHA512 c7f34b20fbfe3300957d1e73a6237850209b55ed08f7d9de1e5dc710fcce8360e359136f8f996aedb38620ae08122e3e1c44922c60db6c16a1d57711d47a8c61
diff --git a/dev-python/minidb/minidb-2.0.4.ebuild b/dev-python/minidb/minidb-2.0.4.ebuild
new file mode 100644
index 000000000000..4f6ce1effae1
--- /dev/null
+++ b/dev-python/minidb/minidb-2.0.4.ebuild
@@ -0,0 +1,20 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_REQ_USE="sqlite"
+DISTUTILS_USE_SETUPTOOLS=no
+
+inherit distutils-r1
+
+DESCRIPTION="Simple SQLite-based object store"
+HOMEPAGE="https://thp.io/2010/minidb/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+distutils_enable_tests pytest